USB thumbdrive keeps automatically remounting

Mark A. Maupin mark at
Thu Mar 5 07:49:52 PST 2009

I am running freebsd 7.1, with Gnome.
I have gnome_enable="yes" and dbus_enable="yes" in my rc.conf and my usb key gets auto-mounted when i plug it in.

My problem is, when i unmount the drive (either by right clicking the icon on the desktop, or by umount command)
the drive immediately remounts, and the window showing files on the drive pops up again.

The only way i can remove the drive is by killing hald, remove the drive, and restart hald.

This DOES NOT happen with any other usb drives i have used on this system, including mp3 players.

The only difference i can find (other than size) between this usb device and others I've used, is that this one
shows up as /dev/da0(s1) AND /dev/msdosfs/LEXAR, whereas the others only show up as /dev/da0(s1).

All get mounted in /media/<labelname>

I've been looking into this on and off  since December (got it for Xmas), and have yet to find a solution...

Does anyone have any insight as to what could be causing this problem on this particular device? I've tried reading up
on hald to see if i could find anything to help but I'm stumped. I tried one suggestion on creating/editing an fdi file
i had found on a forum, but to no avail. 

Asking for help is really a last resort for me, this is the first time that patience, persistence, and a good deal of googling/man page reading hasn't solve a problem for me.

More information about the freebsd-questions mailing list