link to dos2unix

Fbsd1 fbsd1 at
Sun Mar 1 02:52:48 PST 2009

Roland Smith wrote:
> On Sun, Mar 01, 2009 at 05:00:27PM +0800, Fbsd1 wrote:
>> I use the dos2unix console command all the time. I am tried to typing in 
>> that long name. I tried to do a hard link on it.
>> ln /usr/local/bin/dos2unix /usr/local/bin/d2u
>> This command is accepted without error, but when it execute it
>> d2u xxxx.txt
>> I get message ==oops you renamed me using unix2dos instead.
>> I also tried
>> ln -s /usr/local/bin/dos2unix /usr/local/bin/d2u
>> and got same results. ls -l does not show dos2unix as linked all ready.
>> What am I doing wrong here?
> Usually, programs like this perform dos2unix or unix2dos translations
> depending on how they are called. So renaming them won't work.
> Try adding an alias to your favorite shell. That should work. E.g.put
> 'alias d2u dos2unix' and 'alias u2d unix2dos' in your .cshrc.
> Roland

Thank you. That worked.

More information about the freebsd-questions mailing list