named startup problems upgrading from 7.1p4 to 7.1p5 or 7.1p6

Ian no-spam at
Sun Jun 28 12:35:02 UTC 2009

On Sun, 28 Jun 2009 21:43:49 Matthew Seaman wrote:
> Ian wrote:
> > Hi, I've been meaning to sort this out since the release of 7.1p5, but
> > only just got around to it - I have an installation of 7.1 that runs bind
> > and has been working fine up until I tried to update the system to 7.1p5
> > (using freebsd-update). As soon as I apply the update & reboot, named
> > loads but the startup script hangs.
> >
> > If I press Ctrl+C, the system continues to boot. If I then run
> > /etc/rc.d/named start, named starts, but again the script hangs. I can do
> > DNS lookups while named is running, so it seems to be functioning ok.
> > I tried adding various echo statements to /etc/rc.d/named and found that
> > the script seems to run right through. The hang occurs where /etc/rc.subr
> > echoes out "Starting named" after the named script has run and that's
> > where things seem to stop! Nothing else that is started by the rc.d
> > scripts hangs, so I'm guessing  /etc/rc.subr is ok.
> >
> > I did a diff of /etc/rc.d/named before & after the upgrade from p4 to p5
> > (or p6 which has the same issue) and there are no changes to the file.
> > Nothing seems to be logged anywhere that shows a problem, so I really
> > have no idea what to check next.
> >
> > The only named entry in rc.conf is named_enable="YES". Doing a
> > freebsd-update rollback restores normal operation and given that bind
> > actually loads 7 seems to work apart fromthe hanging script, I suspect
> > there's nothing wrong with my bind configuration.
> >
> > Any suggestions?
> Are you sure it's not the thing which starts immediately *after* named that
> is hanging?  Try running:
>    # rcorder /etc/rc.d/* /usr/local/etc/rc.d/*
> and see what should come next.  Note this command shows the order in which
> all of the rc scripts in those directories would run, not just the ones you
> have enabled in rc.conf, so you may well have to skip a few lines until you
> get to something that is enabled.
> 	Cheers,
> 	Matthew

Well the fact that if I run  /etc/rc.d/named manually after the system has 
booted, the script also hangs suggests it's not the next process
I have just check however & ntpdate is the next one in the list to be started 
and that does start correctly - you can see it report the clock being 
adjusted. Also, when you do a Ctrl+C to break the named script on bootup, it 
says "Script /etc/rc.d/named interrupted".

Something I've just realised is that named stays loaded even when you 'break' 
the script. on bootup and DNS lookups work (I didn't think that was the case 
originally, but it is).

gpg key:
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
Url :

More information about the freebsd-questions mailing list