named startup problems upgrading from 7.1p4 to 7.1p5 or 7.1p6

Ian no-spam at
Sun Jun 28 11:52:01 UTC 2009

Hi, I've been meaning to sort this out since the release of 7.1p5, but only 
just got around to it - I have an installation of 7.1 that runs bind and has 
been working fine up until I tried to update the system to 7.1p5 (using 
freebsd-update). As soon as I apply the update & reboot, named loads but the 
startup script hangs.

If I press Ctrl+C, the system continues to boot. If I then run /etc/rc.d/named 
start, named starts, but again the script hangs. I can do DNS lookups while 
named is running, so it seems to be functioning ok.
I tried adding various echo statements to /etc/rc.d/named and found that the 
script seems to run right through. The hang occurs where /etc/rc.subr echoes 
out "Starting named" after the named script has run and that's where things 
seem to stop! Nothing else that is started by the rc.d scripts hangs, so I'm 
guessing  /etc/rc.subr is ok.

I did a diff of /etc/rc.d/named before & after the upgrade from p4 to p5 (or 
p6 which has the same issue) and there are no changes to the file.
Nothing seems to be logged anywhere that shows a problem, so I really have no 
idea what to check next.

The only named entry in rc.conf is named_enable="YES". Doing a freebsd-update 
rollback restores normal operation and given that bind actually loads 7 seems 
to work apart fromthe hanging script, I suspect there's nothing wrong with my 
bind configuration. 

Any suggestions?

gpg key:
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
Url :

More information about the freebsd-questions mailing list