Firefox crashes on

Manish Jain invalid.pointer at
Sun Jun 28 08:54:07 UTC 2009

Frank Shute wrote:
> On Sat, Jun 27, 2009 at 01:31:09PM +0530, Manish Jain wrote:
>> Hi,
>> This seems to be a strange problem with Firefox which I never 
>> encountered on my old system. Both Firefox2 and Firefox3 work well the 
>> other sites I have tried accessing, but crash on navigating to
>>> /usr/home/emmjanex # firefox3 &
>>> [1] 2668
>>> /usr/home/emmjanex # NP_Initialize
>>> New
>>> SetWindow
>>> SetWindow
>>> NewStream
>>> WriteReady
>>> Write
>>> decoding...
>>> The program 'firefox-bin' received an X Window System error.
>>> This probably reflects a bug in the program.
>>> The error was 'BadImplementation (server does not implement operation)'.
>>>  (Details: serial 31 error_code 17 request_code 140 minor_code 5)
>>>  (Note to programmers: normally, X errors are reported asynchronously;
>>>   that is, you will receive the error a while after causing it.
>>>   To debug your program, run it with the --sync command line
>>>   option to change this behavior. You can then get a meaningful
>>>   backtrace from your debugger if you break on the gdk_x_error() 
>>>   function.)
>>> [1]+  Exit 1                  firefox3
>> There is nothing relevant to the crash in Xorg.0.log or console.log
> Have you tried Firefox3.5? It's in ports as www/firefox3-devel.
> I just tried Yahoo! and had no problems.
> Regards,

Hi Frank,

The problem is not restricted to firefox or There are other 
sites too where this happens. I built Galeon from ports, and it shows 
exactly the same behaviour as firefox2/firefox3 for those sites. So does 
Epiphany (installed from the distribution media).

I doubt whether firefox-3.5 could solve the problem. This seems to be a 
problem with a core library in X or one of the graphics libraries.

Manish Jain
invalid.pointer at

Laast year I kudn't spell Software Engineer. Now I are won.

More information about the freebsd-questions mailing list