apache22: "Can't access startfile"

Glen Barber glen.j.barber at gmail.com
Sun Jun 28 00:21:04 UTC 2009

On Sat, Jun 27, 2009 at 8:10 PM, Gary Kline<kline at thought.org> wrote:
> On Sat, Jun 27, 2009 at 07:38:35PM -0400, Glen Barber wrote:
>> On Sat, Jun 27, 2009 at 7:32 PM, Gary Kline<kline at thought.org> wrote:
>> >
>> >        :-) [above].   no the reboot got things launched.  my server is
>> >        "sage.thought.org", but the mail, web, and dns stuff are all in
>> >        a jail, "aristotle.thought.org", so my guess is that things were
>> >        blocked at sage.  i realize that's a really LAME excuse... :-)
>> >
>> I'm confused.  Everything works now?
>        still checking, but seem to.  i'll check my /var/log/httpd/* files next.
>        That excuse was my best SWAG, and nothing more.  sometimes, reinitializing
>        everything, the OS turns out to be smarter than the rest of us...

I think they call that 'Skynet'. ;)

>> >        if ever i find somebody out here in the seattle area to help me, i'll buy
>> >        a Dell and built ns1.thought.org as aristotle.thought.org; no mo' jails.
>> >
>> >        meanwhile, if anybody else has some clues re wha' happened, Pulleze clue
>> >        me in. there was nothing in the error log; it was dated
>> >
>> Perhaps the logs didn't rotate?  When was the last time that the
>> access log was 'touch'ed?
>        where do i check, glen?  my favoite place to grep around is /var/logs,
>        and the httpd-error.log has some potentially serious [warn]ing messages,
>        but i'm not familiar with apache22.

There should be a httpd-access.log -- 'ls -a' should show you the last
time it was modified, but reading the tail of it should show the last
time it was accepting input.

>        until my network began falling apart
>        in dec, 2007, i was happy as a clam with apache13.  jon horne installed
>        22 and things just-worked.
>        can you or anybody else make sense of any of this::
> [Sat Jun 27 15:50:12 2009] [notice] SIGHUP received.  Attempting to restart

SIGHUP on apache22 is normal, as it is indicating a forceful shutdown

> [Sat Jun 27 15:50:12 2009] [warn] (2)No such file or directory: Failed to enable
>  the 'httpready' Accept Filter

This is a 'known issue'.  Irrelevant to your problems, AFAICT.

> [Sat Jun 27 15:50:13 2009] [warn] RSA server certificate CommonName (CN) `aristo
> tle.thought.org' does NOT match server name!?

Edit either /etc/hosts or the vhost file to fix this -- whichever does
not contain the `hostname` info.


> httpd-error.log: unmodified, readonly: line 48148 of 48148 [100%].

Try 'mv'ing httpd-error.log to httpd-error.log.bak and restarting
apache22 again -- see if this error persists.

Glen Barber

More information about the freebsd-questions mailing list