GCC/GCJ and pdftk

Greg Larkin glarkin at FreeBSD.org
Fri Jun 5 23:10:59 UTC 2009

Hash: SHA1

Greg Larkin wrote:
> Joe Auty wrote:
>> Hello,
>> I'm a little confused.
>> I need pdftk to compile on an amd64 system, and see in the pdftk
>> Makefile the following:
>>> # gcj/libgcj don't exist on these platforms
>>> NOT_FOR_ARCHS= amd64 ia64 sparc64
>> However, I've also read in the pdftk port logs that gcj is included in
>> GCC 3.4+ when WITHOUT_JAVA in the GCC Makefile is set to no or commented
>> out. So, I compiled GCC with gcj support without a problem, and
>> commented out the NOT_FOR_ARCHS line above to force an install of pdftk:
>>> ===>   pdftk-1.41 depends on executable: gmake - found
>>> ===>   pdftk-1.41 depends on shared library: gcj - not found
>>> ===>    Verifying install for gcj in /usr/ports/lang/gcc42
>>> ===>   Returning to build of pdftk-1.41
>>> Error: shared library "gcj" does not exist
>> gcj does indeed exist in /usr/ports/lang/gcc42:
>>> # find /usr/ports/lang/gcc42 -name "gcj"
>>> /usr/ports/lang/gcc42/work/gcc-4.2-20090325/libjava/gnu/gcj
>>> /usr/ports/lang/gcc42/work/gcc-4.2-20090325/libjava/gcj
>>> /usr/ports/lang/gcc42/work/build/gcc/gcj
>> Any suggestions as to what I can do to build pdftk? This particular
>> project will surely be much harder if I can't get pdftk to build/compile...
>> Thanks very much in advance!

Hi Joe,

Yes, that was perfectly clear to me, and I tried a test build of gcc42
with Java support enabled.  It looked like it mostly worked, but there
were some missing executables and packaging errors, so there might need
to be an additional configure argument enabled.

I'll look into it again next week, and I'm sure I'll have to contact the
GCC port maintainer to get his feedback about gcj support on amd64.  I
did read some posts that indicated that even if it builds, it still
doesn't work correctly, but they might have been from a while back.

- --
Greg Larkin

http://www.FreeBSD.org/       - The Power To Serve
http://www.sourcehosting.net/ - Ready. Set. Code.
Version: GnuPG v1.4.7 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the freebsd-questions mailing list