The Gimp

Rob Hurle rob1940 at
Tue Jul 21 00:41:05 UTC 2009

Thanks for all the replies to my question about The Gimp:

2009/6/26 Tim Judd <tajudd at>:
> On 6/23/09, Rob Hurle <rob1940 at> wrote:
>>   Due to some meteorological disasters I've had to replace my 6.1
>> FreeBSD system and I've installed 7.2 on the refurbished i386
>> computer:
>> freebsd [22:03] ~>uname -a
>> FreeBSD 7.2-RELEASE FreeBSD 7.2-RELEASE #0:
>> Fri May  1 08:49:13 UTC 2009
>> My desktop is KDE Version 4.2.2 (not yet sure that this is an
>> improvement over the previous version).  I'm starting to re-install
>> software using portupgrade (portinstall).  I've a few problems with
>> that, but I'll leave that to another post.  The immediate problem is
>> that I've used portinstall to install gimp (picture processing
>> software) which I was happily using on the previous version.  It
>> installs OK (after a fearful amount of time) but when I start it, I
>> get a segmentation fault:
>> freebsd [22:07] ~>gimp &
>> [1] 3696
>> freebsd [22:09] ~>
>> [1]    Segmentation fault            gimp
>> freebsd [22:09] ~>
>> If I run as root, there is no problem:
>> freebsd [22:09] ~>sudo gimp &
>> [1] 3700
>> freebsd [22:10] ~>
>> [1]  + Suspended (tty output)        sudo gimp
>> freebsd [22:10] ~>fg
>> sudo gimp
>> Password:
>> freebsd [22:11] ~>
>> It starts OK and I can use it fine.  The config file ".gimp-2.6" is
>> saved in root's home directory.  I've tried RTFM, but there is no
>> information on this problem.  Maybe it's due to some library having
>> the wrong permissions and I should search the system for files with
>> 544 permissions or something.  Does anyone have a clue as to what's
>> going on, or should I report a bug?  Thanks heaps.
>> Rob Hurle
> Rob,
> Any chance you're using something like Kerberos, *SQL, LDAP, NIS, or
> some other remote database to login to your system?
> Is it all local users, or are they all from remote?

In fact,  it is all users.  I have now moved back to KDE 3.5.10 (a big
improvement over KDE 4.2.2) and the problem is still there - gimp-2.6
runs OK as root, but segfaults when run by any other user.  I've
reinstalled gimp-app:

portupgrade -rR gimp-app

still got the problem.  I've "solved" it by setting the executable in
/usr/local/bin to suid:

freebsd [10:24] /usr/local/bin#ll gimp-2.6
-r-sr-xr-x  1 root  wheel  4245892 20 Jul 14:19 gimp-2.6

Not nice, but it now works with any user, however the ownership of
files in the ~/gimp-2.6 directory is now "root".  Previously I'd
"solved" the problem by running always as root but then it never made
a ~/gimp-2.6, but always used the ~root/gimp-2.6 directory, for every
user.  I've also tried setting the ownership of the executable to bin,
but that also fails.  Any ideas for a better solution would be
welcome.  Meanwhile, I'm OK.

Rob Hurle
Rob Hurle
Research School of Pacific and Asian Studies, ANU
e-mail:              rob1940 at
Telephone (ANU): +61 2 6125 3169
Mobile (in VN):  +84 948 243 538 (Currently in Australia)
Mobile (in OZ):  +61 417 293 603 (Currently in Australia)

More information about the freebsd-questions mailing list