Binary nVidia-driver with GeForce2 Integrated GPU

Frank Steinborn steinex at
Sun Jul 19 10:48:27 UTC 2009

Rafal Grodzinski wrote:
> Frank Steinborn wrote:
>> Hi list,
>> I have a box with a GeForce2 MX/MX400 onboard on an nForce-chipset and
>> want to use the binary nVidia-driver with it. I have to use the legacy
>> driver (96.43.13). It installs without problems, and the GPU gets
>> detected properly: 
>> nvidia0: <GeForce2 Integrated GPU> on vgapci0
>> vgapci0: child nvidia0 requested pci_enable_busmaster
>> vgapci0: child nvidia0 requested pci_enable_io
>> nvidia0: [GIANT-LOCKED]
>> nvidia0: [ITHREAD]
>> However, if I start X, strange things happen. The video is shown, but
>> there are many artifacts and all looks kind of strange - it is
>> unusable. I can see the following from the nVidia-driver in dmesg
>> after X started:

[ ... ]

>> What I've done so far to track this down:
>> - Tried the driver from ports (atm in version 96.43.11) and the one
>>   from the website (96.43.13).
>> - installed compat5x (The nVidia page claims this is necessary).
>> - I tried with agp-support from the nVidia-driver and with agp-support
>>   from the FreeBSD kernel.
>> All that did not changed the observed beharviour. I would be more than
>> happy if someone could provide me with a hint...
> Hello Frank,
> I'd advise you to try out different versions of nvidia driver from  
> ports, especially x11/nvidia-driver-71 as it's quite an old card.
> I have GeForce 6100 and if I use anything different than  
> x11/nvidia-driver-173 I get some random issues.
> If you still get issues with x11/nvidia-driver-71 I think that you  
> should check out some older drivers from nvidia web site.
> About your xorg.conf file I don't think that you need to have both  
> Option       "DPMS"
> and
> HorizSync    30-60,
> VertRefresh  50-76
> set at the same time. As I understand it DPMS means that graphics card  
> reads these information directly from screen so you don't have to set it  
> yourself. I've got only
> Option       "DPMS"
> set and it works fine.
> Rafal


thanks for your reply. I tried the 71-driver, and this panics my
system instantly. So no luck here. Older 96 versions of the driver are
not really usable, since they are not compatible with xorg-server-1.6.


More information about the freebsd-questions mailing list