upgrade from Firefox 3.0 to Firefox 3.5 -- now that it's installed, it won't run

Chad Perrin perrin at apotheon.com
Sat Jul 18 19:43:08 UTC 2009

On Sat, Jul 18, 2009 at 08:06:58PM +0200, Frank Steinborn wrote:
> Ok, now this seems to be a problem with libpthread-stuff. The problem
> only exists in 6.x. Sorry that I did not mention that earlier, but it
> just crossed my mind right now... However, someone is working at it.
> He also mentions some workarounds you could try.
> Please read the thread "www/firefox35 coredumps every time at startup"
> on ports at .

That doesn't seem to have worked out for me, either, exactly.  I tried
creating the /etc/libmap.conf file as offered for a workaround:

    libpthread.so.2             libthr.so.2
    libpthread.so               libthr.so

. . . but this is the result:

    > firefox3

    (firefox-bin:39533): GLib-GObject-WARNING **:
    IA__g_object_weak_unref: couldn't find weak ref 0x29e9ce10(0x809a330)
    Segmentation fault

I seem to have unsubscribed from freebsd-ports@ a while ago, so I can't
just respond in-thread to the "www/firefox35 coredumps" discussion there.
Would it be better for me to start a new thread on freebsd-ports@ rather
than continue discussing it here?

Chad Perrin [ original content licensed OWL: http://owl.apotheon.org ]
Quoth Dennis Miller: "Bill Gates is a monocle and a Persian Cat away
from being the villain in a James Bond movie."
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20090718/a85f7e34/attachment.pgp

More information about the freebsd-questions mailing list