badly munged system

Daniel Marsh jahilliya at
Sat Jul 18 01:12:21 UTC 2009


The actual problem is the fact you installed the kernel, booted the
new kernel and are using the "old" world.

You can boot the old kernel and do a make installworld and it will work.

The world and the kernel will have problems, especially if there are
major version differences between the new and old builds!

Keep the kernel the same version of the world by installing world and
kernel at the same time.



On 7/18/09, Eitan Adler <eitanadlerlist at> wrote:
> I tried to do a make buildworld, make buildkernel, make installkernel,
> reboot, make installworld from an old version of 7.2-STABLE to revision
> 195666. I was in single user mode the entire time.
> The first three steps worked perfectly. The final step resulted in an
> error which I forgot to log. I then proceeded to do a make clean and try
> to rebuild the world.
> This results in the following error:
> cc -O2 -fno-strict-aliasing -pipe
> -I/usr/obj/home/src/stable7/tmp/legacy/usr/in
> clude -c /home/src/stable7/usr.bin/makewhatis/makewhatis.c
> /home/src/stable7/usr.bin/makewhatis/makewhatis.c:146: warning: 'struct
> dirent'
> declared inside parameter list
> ....
> /home/src/stable7/usr.bin/makewhatis/makewhatis.c:929: error:
> dereferencing poin
> ter to incomplete type
> *** Error code 1
> Stop in /home/src/stable7/usr.bin/makewhatis.
> *** Error code 1
> ...
> Along with this error I am now missing quite a number of system files:
> among them include /usr/share/mk/
> /libexec/ sort: Shared object has no run-time symbol table
> and man.
> How could I get out of this state without losing data?
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

Sent from my mobile device

More information about the freebsd-questions mailing list