Install from a USB Pen

Fbsd1 fbsd1 at
Fri Jul 17 07:21:50 UTC 2009

Randi Harper wrote:
> On Wed, Jul 15, 2009 at 6:50 PM, Fbsd1 <fbsd1 at> wrote:
>> Randi Harper wrote:
>>> On 7/14/09, Fbsd1 <fbsd1 at> wrote:
>>>> What are the instructions for using this 8.0 memstick.img?
>>>> What raw size memstick is needed?
>>>> Is the 8.0 memstick.img the same content as the cd1 disk?
>>> Sigh. Reply-to-all fail. Resending.
>>> It's all in the email about the 8.0 BETA(s). Use dd, a memstick that
>>>  is of equal to or greater size than the memstick.img, and no, it's
>>>  different from disc1. It currently lacks packages, but it does include
>>>  livefs.
>>>  -- randi
>>>  The email about 8.0 BETA(s) was not posted to the questions list that is
>> why I did not see it.
>> This is what I tried
>> $$$$ Plugging in the stick auto generated these messages
>> # /root >umass0: <vendor 0x0930 USB Flash Memory, class 0/0, rev 2.00/2.00,
>> addr  2> on uhub1
>> da0 at umass-sim0 bus 0 target 0 lun 0
>> da0: < USB Flash Memory 6.50> Removable Direct Access SCSI-0 device
>> da0: 1.000MB/s transfers
>> da0: 1905MB (3903487 512 byte sectors: 255H 63S/T 242C)
>> GEOM_LABEL: Label for provider da0s1 is msdosfs/ço¤żňÚktń
>> $$$$ I have to hit enter key to get prompt
>> $$$$ of=da0  or of=da0s1 resulted in same thing, no img on stick
>> # /usr >dd if=8.0-BETA1-i386-memstick.img of=da0 bs=10240 conv=sync
>> 57412+0 records in
>> 57412+0 records out
>> 587898880 bytes transferred in 192.035793 secs (3061403 bytes/sec)
>> Can not mount with (mount /dev/da0s1 /mnt)
>> But (mount_msdosfs /dev/da0s1 /mnt) does work but
>> stick still contains the original data.
>> Has not been overwritten by the 8.0-BETA1-i386-memstick.img
>> What is the problem here?
> You're writing to a file called da0 inside /usr instead of /dev/da0.
> -- randi
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

dd if=8.0-BETA1-i386-memstick.img of=/dev/da0   worked

I used my laptop to boot from the usb memstick. The 8.0 sysinstall 
started right up but it has problems. In this test i am booting off a 
2gb usb memstick containing the 8.0-BETA1-i386-memstick.img and 
installing on a second 8gb memstick.

While trying to do a [STANDARD/KERNEL DEVELOPER] distribution 
sysinstall issues error msg saying package index not on current media 
them gos on to tell me that docproj, manpages, proflibs, dict, info, 
sbace, ssys and srce are not on the media.

I take this to mean that they are missing from the 

So I tried to install again this time doing a minimal selection. This 
when through to completion but the resulting memstick was not bootable.

I'll try this test again when BETA2 is released.

More information about the freebsd-questions mailing list