Attempting ZFS Only Install of 7.2

Andrey V. Elsukov bu7cher at
Thu Jul 16 07:52:29 UTC 2009

Jason Garrett wrote:
> Top Post, I know... but has anyone on @current tried a full on ZFS on ROOT
> Both Drew and I have both tried the guide at
> (dead
> link now :( )
> I get as far as the message I detailed before using parts from another
> guide. I am hoping for both of us, that someone here knows even a little
> bit.

I installed 8.0-BETA1 on ZFS 2 days ago. It works. I did following steps:

1. Boot from bootable USB-flash (Minimal FreeBSD installation with copy of install CD).

2. Create partitions
# gpart show ad0
=>       34  312581741  ad0  GPT  (149G)
          34        256    1  freebsd-boot  (128K)
         290    4194304    2  freebsd-swap  (2.0G)
     4194594  251658240    3  freebsd-zfs  (120G)
   255852834   56728941       - free -  (27G)

3. Create zpool and filesystem hierarchy

4. Install FreeBSD from copy of install CD to ZFS. I used sysinstall with custom
options (Install Root and Media Type)

5. Create /etc/fstab, /etc/rc.conf, /etc/src.conf, /boot/loader.conf

6. Install ZFS aware /boot/loader

7. Create zpool.cache

8. Install ZFS boot:
# gpart bootcode -b /zroot/boot/pmbr ad0
# gpart bootcode -p /zroot/boot/gptzfsboot -i 1 ad0

9. Change mount points for zroot pool and reboot.

It's all.

WBR, Andrey V. Elsukov

More information about the freebsd-questions mailing list