Attempting ZFS Only Install of 7.2

Jason Garrett kingedgar at
Wed Jul 15 22:12:30 UTC 2009

On Mon, Jul 13, 2009 at 18:09, Drew Tomlinson <drew at>wrote:

> Jason Garrett wrote:
>> On Mon, Jul 13, 2009 at 13:30, Drew Tomlinson <drew at<mailto:
>> drew at>> wrote:
>>    Jason Garrett wrote:
>>        >snip
>>        I see you tried the zpool import and export, but did you
>>        perform `mkdir /boot/zfs` directly before `zpool export tank
>>        && zpool import tank` ?
>>        I just have to ask because I did not see that specified, and
>>        you mention not being able to find zpool.cache. /boot/zfs is
>>        where zpool.cache hides out.
>>    Yes I did.  However I figured out my problem.  I was chrooted into
>>    /dist and the zpool.cache was being written to /boot/zfs (as you
>>    mention).  But because of the chroot, when I checked /boot/zfs, I
>>    was *really* checking /dist/boot/zfs.  Thus my problem.  :)
>>    However I'm still having difficulty.  I suspect I don't have a
>>    /boot/loader that supports zfs filesystems as I just boot to the
>>    'OK" prompt.  An 'lsdev' only shows BIOS devices but I've seen
>>    posts on the Net that indicate I should have zfs devices listed
>>    there too if I have a proper /boot/loader.  I've used the one from
>>    both 7.2-RELEASE.iso and 8.0-BETA1.iso but no luck.  Do you know
>>    of any way I can confirm or deny my suspicion?
>> I am in the same spot you are now. I started the process yesterday but had
>> to quit because it got too late. Apparently the few who have written these
>> guides have gotten it to work, but that still eludes me. I'll post back if I
>> get it working or have any new developments.
> Well you're doing better than me.  I've been at this for about 10 days off
> and on.  :)
> Cheers,
> Drew

Ok, now a few days later and still frustrated. Basically I narrowed my
install down to one drive, divided up with gpt. I used a few sections from - specifially the section on
installing the sources from /dist/8.0-BETA1 as well as rebuilding the loader
as this guide says.

I actually got it to load the kernel, goes through that ok. As soon as it
tries to mount the root filesystem, it hangs with the following messages.
(Won't respond to the keyboard anymore)


Trying to mount root from zfs:zroot
If you have invalid mount options, reboot, and first try the following from
the loader prompt:

            set vfs.root.mountfrom.options=rw (did this,no luck.. also
switched to an /etc/fstab layout, still no go)

and then remove the invalid mount options from /etc/fstab.

Loader Variables:
vfs.root.mountfrom.options=rw,noatime (this is from the /etc/fstab attempt)


Then it describes some specifications on how to use the <fstype>:<device>.

I just don't get how some are getting this working, yet it comes so hard for

Drew, I hope you have had better luck than I. I may just give up until it is
a viable solution.

> --
> Be a Great Magician!
> Visit The Alchemist's Warehouse

More information about the freebsd-questions mailing list