Server screwed up (/lib/ Undefined symbol "_nsdispatch")

Victor Starenky freebsd at
Tue Jul 14 03:42:35 UTC 2009

Hi guys,
I was running FreeBSD server at home for a few years on an old box for mail,
some web and ftp etc. I've been through a number of upgrades even though
it's not easy with the box as old as this one (PII 350). Right now I'm at
7.0 Release.
Now last weekend something's screwed up there pretty badly and machine is
pretty much unusable.
The sympthom is that pretty much any command results in the following error:
/libexec/ /lib/ Undefined symbol "_nsdispatch"
Specifically this is thrown when trying to login (after entering login name)
on the console, ssh, ftp.
This is also thrown for "fetch"or for "ls -l" (plain ls works).
So I'm lucky to have one root session on the console as I can't login at any
Most recent thing that might have something to do with it would be an
(unsuccessful) attempt to portupgrade cups-base. This failed with the error
message of wrong cups client. Now this is not new and I have a number of
ports that wouldn't upgrade - cups-base, apache for example. But before
portupgrade would fail without affecting the system. Same cups-base failed
before without any side effects.
As I said this might have nothing to do with the errors I'm getting, just
most recent my actions.
So currently server is not usable - it won't even accept mail (Currier
server) with the same error message.
I tried portupgrade bash but portupgrade itslef also fails with the same
message. I do have one mean of getting new files there through mounted smb
directory. I've tried putting all new bash files into
/usr/ports/distfiles/bash but portupgrade still fails (just a bit further
I ran pkg_libchk which shows a bunch of missing libraries, mostly for
compat4x-i386-5.3_9 but for example courier also misses one:
courier-0.54.0: /usr/local/libexec/filters/perlfilter misses
At this point I think I'm lost. I'd really rather avoid complete reinstall
of the server if possible.
I would greatly appreciate any help troubleshooting the libraries. Still
hope there is something that can be done other than reinstall.
Thanks in advance!

More information about the freebsd-questions mailing list