Problem with make buildworld during upgrade from 7.0-RELEASE to 7.2-RELEASE

Joseph Bashe joseph.bashe at
Mon Jul 13 22:05:41 UTC 2009


I am going thru my first FreeBSD upgrade and it's not going too smoothly. I
originally started the upgrade using the "freebsd-update" method. This is
what I've done so far (all as root user):

PS. I am using a custom kernel.

1. ran "portsnap fetch update" - [success]

2. ran "portupgrade -va" ["portupgrade"not found - i hadn't installed it

3. ran "freebsd-update fetch" [success] (i know this was out of sequence
from the guide)

4. installed portupgrade ("make install clean" from the dir in ports) [ssh
connection dropped, so i had to login again]

5. installed portupgrade ("make install") [success] then "make clean"

6. ran "portupgrade -va" [long process begins... strangely, several X
components install although this is not desired]

7. ran "freebsd-update fetch" again [success]

8. ran "freebsd-update upgrade -r 7.2-RELEASE" [ssh connection dies during
"preparing to download files", so i log in again]

9. ran "freebsd-update upgrade -r 7.2-RELEASE" [~27,000 updates..] and of
course ssh connection dies during "Fetching 3060 files" although "applying
patches" succeeds. A note: these disconnects are not at all common during a
normal ssh connection to this computer, it seems due to the resource-intense
operations required for updating freebsd.

10. log back in, ran "freebsd-update upgrade -r 7.2-RELEASE" [..success]

11. ran "freebsd-update install" [and of course ssh dies during "Installing

12. log back in, ran "freebsd-update install".

13. Then i ran nextboot -k GENERIC and got "/boot/GENERIC doesn't exist".
so, i copied kernel.old to /boot/GENERIC

14. Ok, maybe this was the problem. for some reason at this point i decide
to run "freebsd-update install" again, and get "no updates are available".

15. Then I run "freebsd-update -r 7.2-RELEASE upgrade" again.. it downloads
some patches, but then i get this error: "/usr/sbin/freebsd-update: cannot
open files/.gz: No such file or directory" about 100 times.. plus, i get
questions like

"The following file will be removed, as it no longer exists in
FreeBSD 7.2-RELEASE: /boot/device.hints
Does this look reasonable (y/n)?"

which doesn't look very good.

16. so, i issued a shutdown -r now command and crossed my fingers.. the
system is still up, but it hasn't been upgraded (uname still reports 7.0-p11
for booting form the GENERIC kernel, and 7.0-p9 for the custom kernel). on
top, make buildworld fails with:

"Stop in /usr/src/secure/lib/libssh.
*** Error code 1 "

every time.

and worse,

any csup command dies with "/libexec/ /lib/ version
FBSD_1.1 required by /lib/ not found" along with a lot of other
commands... any ideas??

Just want to note that I log every keystroke on my servers so just let me
know any specifics would help you in diagnosing the problem.

Many thanks!
Joe Bashe

More information about the freebsd-questions mailing list