Second disks causes invalid partition when booting/no disks found in sysinstall

Hans F. Nordhaug Hans.F.Nordhaug at
Tue Jul 7 16:58:00 UTC 2009


I have been running FreeBSD happily for several years on the same old
hardware. 2 weeks ago when I was on vacation one of the disks started
to have problems, and 5 days ago the disk just stopped working - far 
too many read failures to get anything mounted. I got a new disk 
yesterday (finally home from vacation). The problems started when I
tried to install FreeBSD 7.2 - I got "no disks found" from sysinstall
all the time. The BIOS reported happily the new master and the old
slave/hard drive. OK, I just disconnected the old slave and was able to
install FreeBSD on the master. I was thinking/hoping that with the OS 
in place I should be able to read the old slave (which was one single
UFS partition). Anyway, if I connect the old slave/hard drive I get
"invalid partition" when booting - argh!

What should/can I do? If I run the Live CD (livefs), I of course get
"no disks found" ...

Hans Nordhaug

PS1! The old setup was running FreeBSD 6.3. 

PS2! The slave was used for back-up so it's kind of essential that I'm
able to read it...

PS3! I install the FreeBSD boot manager, but I guess that it doesn't
make any difference.

More information about the freebsd-questions mailing list