Urgent help needed : portmaster dies on py-cairo

Manish Jain invalid.pointer at gmail.com
Mon Jul 6 01:31:29 UTC 2009


This is not a portmaster problem, but a problem of getting py-cairo 
to build following an update in the ports directory.

3 days back I ran 'portsnap fetch extract'. Then yesterday I ran 
'portsnap fetch update' followed immediately by 'portmaster -a -B'

After 3-4 hours, portsnap died on graphics/py-cairo saying :
cannot find python headers

/usr/ports/graphics/py-cairo/work/pycairo-1.8.4/config.log says :
configure:4734: cc -E -I/usr/local/include conftest.c
conftest.c:10:28: error: ac_nonexistent.h: No such file or directory
configure:4741: $? = 1

cd /usr
find . -name 'ac_nonexistent.h'
#no results

py-cairo-1.8.4 needs python2.6. My system has both python2.5 and 
python2.6 installed, with their headers under 
/usr/local/include/python2.5 and /usr/local/include/python2.6 

Any help on enabling py-cairo locate the python headers would be 
greatly appreciated.

My system is totally messed up, half of it updated by portmaster and 
the other half waiting for the update once py-cairo can locate the 
python headers.

Manish Jain
invalid.pointer at gmail.com

More information about the freebsd-questions mailing list