kernel panic on SATA drive

jw jwdevel at
Thu Jul 2 06:57:34 UTC 2009

I've been having an intermittent problem, wonder if someone on the
list has any ideas.

First my setup:
FreeBSD 7.2-RELEASE (amd64)
quad-core Phenom processor
mobo: MSI K9N2G Neo
chipset: NVIDIA GeForce 8200, which FreeBSD recognizes as nForce (not
sure how that works)

I have a 3ware RAID card (RAID 1), which is the boot device.
A seagate drive connected via SATA
A WD external drive via USB

I will have the system running fine, then the seagate will apparently
fall off the bus, resulting in a panic.
The dump fails as well, presumably due to the 3ware driver not being
able to handle the panic? not sure...
If anyone knows a way I can get the dump to succeed, I'd appreciate
that info, too.
See below output for details.

The first time I had the problem, it would regularly happen when I
tried to install a particular port (sudo).
Then I changed where the SATA cable was plugged in and tried
un/re-plugging the USB external drive and rebooting and managed to get
it working (so I thought).
One weird aspect of that process is that the BIOS would not even list
the SATA drive until I switched it to a different plug... freaked me
out a bit.
Also during POST it would hang for many seconds, when I had the USB
drive plugged in, until I went through my random
plugging/unplugging/replugging shenanigans.

But now it has happened again, this time while copying lots of files
from the USB external drive to the SATA one.
Both drives are recognized by BIOS (and FreeBSD) on reboot this time,
at least. But I'm hesitant to just 'call it good' - I'd like this to
be a stable server (:

I manually transcribed the bulk of the output - is there a nicer way
to get the output of a kernel panic so I can copy/paste?
I didn't find an obvious command, though I'm no FreeBSD guru. If
someone could tell me how to get that output, I'd be greatful.

---- output below ----

ad7: FAILURE - device detached
g_vfs_done():ad7s1d[WRITE(offset=340978335744, length=16384)]error = 6
g_vfs_done():ad7s1d[WRITE(offset=340978352128, length=16384)]error = 6
/dev: got error 6 while accessing filesystem
panic: softdep_deallocate_dependencies: unrecovered I/O error
Uptime: 15h23m39s
Physical memory: 7923MB
Dumping 733MB: 718 702 686 670 654 638twe0:completion event for nonbusy command
twe0: completion event for nonbusy command
twe0: completion event for nonbusy command
twe0: completion event for nonbusy command
twe0: completion event for nonbusy command
twe0: completion event for nonbusy command
twe0: status 13207fd2<CQEMPTY,UCREADY,RQEMPTY,MCERR,>

### At this point in the log a bunch of output starts getting
interleaved, character-by-character even.
### Maybe due to multi-cpus dumping output simultaneously? I don't know...
### eventually...

twe0: can't drain AEN queue
twe0: controller reset in progress
twe0: reset 1 failed

### snip more failing messages

twe0: can't reset controller, giving up

#Then some more stuff that I haven't written down

---- end log ---

So.... any thoughts?
Maybe it's just a mobo / chipset compatibility issue? I should have
known with a mobo that says "GeForce 8200" for chipset. I thought
NVIDIA support was pretty good in FreeBSD though...

Do you think recompiling my own kernel would help?
Do you think installing a different version of FreeBSD would help? (My
main experience is with 6.2)

It was quite odd to me that even the BIOS stopped recognizing the SATA
drive the first time. Any thoughts on that?

Thanks for any feedback

More information about the freebsd-questions mailing list