postfix-pipe complains: no such file or directory

Jordi Moles Blanco jordi at
Tue Sep 30 07:37:14 UTC 2008

Hi everyone,

i was wondering if someone has experienced this problem i've been having 
for 2 weeks now.

I'm running Freebsd 7.0 and postfix-2.5.1.

The thing is that i've set up a filter written in C using postfix's 
"pipe" feature. The filter works great most of the times.... but every 
2-3 days.... mainly depending on the amount of load... FreeBSD hangs 
completely(or almost completely) and leaves this message behind:

pipe[44634]: fatal: pipe_command: execvp 
/usr/local/etc/postfix/quota_postfix: No such file or directory.

This file is never touched, i mean, it's still there even when the 
system says it can't find the file.
I've tried to change permissions of the file, just in case. Right now 
the owner is root:wheel, but i've tried "postfix", also "filter", and so on.

in the, i've got this:

# quota_postfix
quota_postfix      unix    -       n       n       -       20      pipe
 flags=R user=filter argv=/usr/local/etc/postfix/quota_postfix 
"localhost" "10028" "${sender}" "${recipient}" "${domain}"

has anyone experienced that? it's a very strange thing that only gets 
fixed when you restart postfix. Sometimes i even have to reboot the machine.
This started happening some weeks after i upgraded from 6.3 to 7.0, i 
had had this script working for over a year without any problem at all.

i would be very  pleased if someone can throw some light on this issue.

Thanks in advance!!!!

More information about the freebsd-questions mailing list