X server crashes on exit

Kevin Kinsey kdk at daleco.biz
Fri Sep 26 03:53:59 UTC 2008

Herman Te wrote:
> Hi,
> I installed 7.0 from the CD with X. Now this is the first time I ever used
> FreeBSD or X, I know a bit from linux but I usually use command line only.
> So when the system finished installing I logged in and typed startx. First
> time it took over 2 mins (is this normal) but eventually worked, and loaded
> 3 green terminals and a small clock in the corner. I don't know what this is
> and the mouse was not working so I tried to exit with the ctrl+alt+backspace
> but screen went black and the entire system hung - I know this as my remote
> session aborted and the keyboard led stopped responding too - still no
> response after 30 mins.
> I realise that i need a window manager so I tried to install gnome from CD.
> However it is the same problem and the system hung when I tried to quit back
> to command line mode. After hours on google I found how to fix the mouse and
> decide to try building fluxbox wm from the ports. Before starting the X, I
> ran Xorg -configure and echo exec startfluxbox > .xinitrc. So now it starts
> up properly and works well but still I cannot exit the X. This is a big
> problem because the machine has no case so I must bend down and touch the
> reset pins with a penknife :P Also as the disks are not unmounted there are
> errors and one of the times my user account was deleted, so I had to
> reinstall the whole system.
> As I said I have never configure or install an X windows system before, and
> I was googling for ages. Could anyone give me some idea of how to diagnose
> and fix this problem?
> Thanks
> Herman

Have you looked at the logfiles? (/var/log/Xorg.$n.log)

Kevin Kinsey
Let your conscience be your guide.
		-- Pope

More information about the freebsd-questions mailing list