Build error while upgrading 'kdesdk-3.5.9' to 'kdesdk-3.5.10' (devel/kdesdk3)

Michal Petrucha johnny64 at
Sun Sep 21 14:51:50 UTC 2008

Replying to myself...

> Hello everybody,
> I get an error while upgrading the port mentioned in $subj. When I run
> # portupgrade -c devel/kdesdk3
> it starts compiling, but after a while it always crashes at this
> point:
> ---------
> Making all in libgettext
> gmake[4]: Entering directory `/usr/ports/devel/kdesdk3/work/kdesdk-3.5.10/kbabel/common/libgettext'
> flex -+ ./pofiles.ll
> /bin/sh /usr/local/bin/libtool --silent --tag=CXX   --mode=compile c++ -DHAVE_CONFIG_H -I. -I../../..   -D_THREAD_SAFE -pthread -DQT_THREAD_SUPPORT   -I/usr/local/include -I/usr/local/include  -I/usr/local/include -D_GETOPT_H -D_THREAD_SAFE   -Wno-long-long -Wundef -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -O2 -fno-strict-aliasing -pipe -march=athlon -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -MT pofiles.lo -MD -MP -MF .deps/pofiles.Tpo -c -o pofiles.lo
> warning: "YY_STACK_USED" is not defined
> warning: "YY_MAIN" is not defined
> gmake[1]: Leaving directory `/usr/ports/devel/kdesdk3/work/kdesdk-3.5.10'
> gmake: *** [all] Error 2
> *** Error code 2
> Stop in /usr/ports/devel/kdesdk3.
> ** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade.2946.0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=kdesdk-3.5.9 UPGRADE_PORT_VER=3.5.9 make
> ** Fix the problem and try again.
> ---------
> Since it crashes while compiling gettext support, I tried to rebuild
> devel/gettext, but with no success. On friday I'll probably try
> # portupgrade -Rf devel/kdesdk3
> as I am getting really desperate, but if anybody has any better
> suggestion, I'd be really thankful. (Rebuilding all of the
> dependencies will be really painful since I am getting ZFS deadlocks
> on a weekly basis, depending on the uptime, and I won't have physical
> access to the machine from morning until afternoon in case it
> hangs...)

All right, so I tried rebuilding all ports devel/kdesdk3 depends on
but in the end I got the same error message. So... Anybody has an idea
what's going on?

> Thanks in advance.
> Michal Petrucha

(-K JohnNy alias Partial Derivative ∂
[icq] 338328204 [abandoned]
[jabber] JohnNy64 at
[skype] JohnNy64-konik [abandoned]
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list