irq19 interrupt storm?

Scott Gasch scott.gasch at
Wed Sep 17 15:00:26 UTC 2008

You're right: atapci1, atapci2, fwohci0 and uhci4 are all sharing the same
irq (19) while irqs 20, 21, 22 at least seem completely unused.  Here's a
dumb question: how do I fix it?  I tried setting "plug and play OS" in the
BIOS and then using device.hints to push different devices to different
irqs.  But every time I tried a new hint it seemed to be ignored.  I was
trying stuff like:

set hint.atapci.1.irq="20"
set hint ata.4.irq="20" (ata4 is a channel on atapci1)
set hint fwhco.0.irq="20"

I also tried to move the dc driver to a new irq as a test.  This was also
seemingly ignored.

I then tried turning "plug and play OS" off in the BIOS but I don't see
anywhere to set the IRQs of the onboard SATA controllers via the menus.  I'm
looking for a BIOS upgrade now... any other advice?


On Tue, Sep 16, 2008 at 7:12 AM, Gary Jennejohn
<gary.jennejohn at>wrote:

> On Mon, 15 Sep 2008 22:57:38 -0700
> "Scott Gasch" <scott.gasch at> wrote:
> > Hi,
> >
> > I'm running freebsd 7.0-RELEASE-p4 on a 4-core amd64 box. Nearly 100% of
> > 1 cpu is constantly being used handling irq19: uhci4 interrupts. This
> > seems to happen both with and without any USB devices plugged in:
> >
> > vmstat -i
> > interrupt total rate
> > irq1: atkbd0 5 0
> > irq6: fdc0 1 0
> > irq17: mskc0 dc0 1180547 18
> > irq18: skc0 uhci2* 163250699 2512
> > irq19: uhci4++ 3187989508 49072
> I think the ++ here indicates that two or more devices are sharing this
> interrupt.  Try doing "grep irq.*19 /var/run/dmesg.boot" to see which
> ones.  One of these devices could be the culprit.
> ---
> Gary Jennejohn

More information about the freebsd-questions mailing list