portmanager errors

Gerard gerard at seibercom.net
Wed Sep 10 11:15:58 UTC 2008

On Tue, Sep 9, 2008 at 11:04 PM, gahn <ipfreak at yahoo.com> wrote:
> Hello:
> I run into errors when i run "portmanager -u":
> 00344 luit-1.0.2_2 /x11/luit
> "Makefile", line 85: Could not find /usr/ports/x11/xorg-clients/../../x11-servers/xorg-server/Makefile.inc
> "Makefile", line 92: Malformed conditional (${X_WINDOW_SYSTEM:L} != xorg)
> "Makefile", line 96: if-less endif
> make: fatal errors encountered -- cannot continue
> MGdbAdd error: attempt to place null data into record halted
> Assertion failed: (0), function MGdbAdd, file MGdbAdd.c, line 78.
> Abort (core dumped)
> could the portmanager bypass the failed "luit" and continue the next one?

First, what version of 'portmanger' are you using? If not "0.4.1_9",
then update. Did you insure that you updated your ports tree just
prior to running portmanager?

After checking the above, try running portmanager like this:

     portmanager -u -l -p -y

See if that corrects the problem.

Gerard at seibercom.net

More information about the freebsd-questions mailing list