Can't start MySQL 5.0.67

Greg Larkin glarkin at
Mon Sep 8 19:34:03 UTC 2008

Hash: SHA1

Joe Tseng wrote:
> So I checked in that directory you suggested and I found this:
> 080908 13:35:05  mysqld started
> 080908 13:35:05 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
> 080908 13:35:05 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
> 080908 13:35:05  InnoDB: Operating system error number 13 in a file operation.
> InnoDB: The error means mysqld does not have the access rights to
> InnoDB: the directory.
> InnoDB: File name ./ibdata1
> InnoDB: File operation call: 'create'.
> InnoDB: Cannot continue operation.
> 080908 13:35:05  mysqld ended
> So my questions are:
> 1. What directory is it referring to?  Is it /var/db/mysql by default?  I just tried to give ownership using chown -R mysql /var/db/mysql but that made no difference.
> 2. I've read also for this kind of issue I have to reinstall the software...  When I initially installed this from ports I didn't use any kind of extra parameters.  Are they needed?
>> From: beech at
>> To: freebsd-questions at
>> Date: Mon, 8 Sep 2008 10:56:48 -0800
>> CC: joe_tseng at
>> Subject: Re: Can't start MySQL 5.0.67
>> On Monday 08 September 2008, Joe Tseng said:
>>> I've got a server running FreeBSD7 and got MySQL 5.0.67 installed
>>> on it today.  I ran mysql_install_db and then assigned the root
>>> password.  I tried to get it running on boot (mysql_enable="YES")
>>> and by hand (/usr/local/etc/rc.d/mysql-server start) but I can't
>>> get the daemon to start.  What else do I need to do to get this
>>> working?
>>>  - Joe
>> Check the logfiles in /var/db/mysql, they will usually tell you what 
>> it's choking on. My first guess without more info would be you 
>> probably don't have something configured correctly.
>> Beech

Hi Joe,

Do you have a my.cnf file anywhere?  If so, look for the following
options and make sure that the directories they are set to are also
accessible by the mysql user:


If that doesn't work, I often use truss
to debug permissions issues like this.  You'll usually be able to tell
from its output what syscall generates an EACCES and causes MySQL to fail.

- --
Greg Larkin       - The Power To Serve - Ready. Set. Code.
Version: GnuPG v1.4.7 (MingW32)
Comment: Using GnuPG with Mozilla -


More information about the freebsd-questions mailing list