FreeBSD7 and realtek 8111C

Popof Popof popof.fpn at
Wed Sep 3 12:22:49 UTC 2008

I have a ASRock Wolfdale1333-GLAN/M2, and I use it in order to run FreeNAS.
FreeNAS is based on FreeBSD in order to simply provide a NAS solution.
With the version of FreeNAS based on FreeBSD 6.3 the NIC wasn't recognize, I
had to download those drivers and to compile them in order to make my NIC
working on FreeNAS.
When I tried the version based on FreeBSD 7 the system doesn't recognize my
NIC. I load the module that i made for my NIC, the system recognize my NIC
but when i tried to assign to it an ip address its stops to work.

Jason, what is the name of the device that you use? Maybe this card isn't
support with the realtek driver on FreeBSD 7 but its use another one. Mine
is rl.

2008/9/3 Jason Lenthe <lenthe at>

> Andrey Slusar wrote:
> > Hello!
> > I have the motherboard with realtek 8111C LAN Card.
> > On FreeBSD6.3 it's card is work fine with driver from realtek wesite -
> > rtl_bsd_drv_v175.tgz archive.
> > Build this driver on 7.0-STABLE is not work. I'm hacked this and
> > driver is compile without problems, but LAN card works is very
> > unstable - system hang,
> > when i'm downoad file ~10 seconds. Maybe there are people who can
> > bring to mind my hack? I'm attached driver and patch.
> I have this board on an Intel D945GCNL motherboard and the driver that
> comes with FreeBSD 7 works just fine for me.  Why are you trying to use the
> driver from the website?
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "
> freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list