FreeBSD 4.8: can't load kernel after doing "cp -R /" to another disk

Glen Barber glen.j.barber at
Sat Nov 29 14:56:00 PST 2008

On Sat, Nov 29, 2008 at 11:37 AM, admin <admin at> wrote:
> Hello, everyone. This is the problem: our SCSI disk with FreeBSD 4.8 on it
> has been failing recently, so I copied its root partition to a fresh IDE
> disk with cp -pR and tried to boot from that. Unfortunately, loader gives me
> this:
> can't load 'kernel'
> can't load 'kernel.old'
> and offers prompt.
> I tried almost any combination of the loader command (like
> 0:ad0(0,a)/boot/loader) but still the same. The kernels are right there:
> /kernel and /kernel.old. Can't the root partition be copied this way? Should
> their location on disk be hardcoded somewhere? Please help me with
> bootblocks etc. as I'm desperately running out of time.

Short of using dump/restore, you should append the -p flag to `cp',
because it preserves permissions.  Follow the advice posted by RW,

Glen Barber

"If you have any trouble sounding condescending, find a Unix user to
show you how it's done."
 --Scott Adams

More information about the freebsd-questions mailing list