FreeBSD 7.0 fdisk issue during installation

Jonatan Evald Buus jonatan.buus at
Fri Nov 21 11:36:01 PST 2008

I tried to install FreeBSD 7.0 on an old server earlier today and ran in to
a number of issues related to slicing and labeling the disk using fdisk.
The drive in the machine is a 40GB Seagate Barracude (ST34001A) installed as
a Secondary Master on the IDE bus using LBA.
The BIOS reports that the drive has 16 sectors pr block, but little else.

When accessing fdisk during install, fdisk complains that the disk geometry
is invalid and sets it to the default geometry for 40GB:
Cylinders: 4865
Heads: 255
Sectors: 63
I've tried with the following configuration based on what was reported by
the BIOS:
Cylinders: 19150
Heads: 255
Sectors: 16
Looking in the manual:, Seagate is
specifying the following logical characteristic:
Cylinders: 16383
Read / Write heads: 16
Sectors pr track: 63
Which of these settings should be the correct one for the fdisk geometry?

Additionally I encountered problems during installation if splitting the
disk into more than 4 slices. This would cause the following error to be
thrown during prior to the install files being copied (when sysinstall was
executing the newfs commands):
"Error mounting /mnt/dev/X on /mnt/usr. No such file or directory"
Using only 4 slices seems to have solved this error, however I'd like the
disk layout to use 5 slices as follows:
/ = 512MB
swap = 2048MB (the machine has 1024MB RAM)
/tmp = 512MB
/var = 2048MB
/usr = whatever remains
I noticed that when having 5 slices, the last slice (/usr) would be named X
rather than ad2s5 as I'd expect (the drive was detected as ad2).
Is this behaviour related to the error in any way?
Also, is the above disk layout good for a server intended to run both a web
server (Apache) and a database server (PostGreSQL) ?

Finally after installation (using only 4 slices) the system will only boot
if the FreeBSD boot manager is used.
This in turn causes a 4 menu options, all of them named "FreeBSD" to appear
during startup despite only the / slice having been set as bootable in fdisk
which appears to be indicated by an "A" in the flag column.
Selecting the first menu item by pressing F1 will make the system boot as
It seems rather silly though to use a boot manager when FreeBSD is the only
operating system that is installed (and ever will be installed) on the
If the FreeBSD boot manager is not used however and only the MBR is set
during installation, the system will fail at startup with error "Invalid
Partition Table".
Is this because the harddrive is installed as the Secondary Master on the
IDE bus?

Appreciate any input on this


More information about the freebsd-questions mailing list