Strange messages by fetchmail: Server certificate verification error

Polytropon freebsd at
Mon Nov 10 23:50:12 PST 2008

On Mon, 10 Nov 2008 22:52:41 -0800, Jeremy Chadwick <koitsu at> wrote:
> First and foremost: this should have gone to freebsd-ports, because
> you're indirectly complaining about ports.  :-) 

Yes, sorry I did. I didn't find anything to complain about FreeBSD
in particular. :-)

> That said: there's a good chance the servers you're fetching mail from
> do not have their certificates signed by a public CA; possibly they're
> self-signed (by their own CA), in which case you need to download a copy
> of the CA and tell fetchmail about it.  The server administrator should
> be able to discuss this with you -- talk to them.

The mailserver are run by Germany's "top Internet company" that
brings the Internet to the masses, it's the one with the twi
digits and the ampersand. Quality isn't their game. :-)

> fetchmail changes severely between minor versions, which is probably why
> your other box running an older fetchmail does not induce this error.
> I'm willing to bet SSL certification verification was enabled between
> the two versions.

I think so, too.

Finally, I did portupgrade ca_root_nss to 3.11.9_2, now everything
works as intended. So the problem is solved and I made a written
note to my "holy pages" how this problem could be solved.

>From Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list