trouble getting x11 xdm to work

Fbsd1 fbsd1 at
Mon Nov 10 15:55:58 PST 2008

Polytropon wrote:
> On Mon, 10 Nov 2008 22:21:38 +0800, Fbsd1 <fbsd1 at> wrote:
>> Also created the .xsessions file in the users home directory.
> The file is ~/.xsession, without an s at the end. I assume
> that csh is your login shell. Put these in your ~/.xsession:
> 	#!/bin/csh
> 	source ~/.cshrc
> 	exec ~/.xinitrc
> This sources your individual user setting from .cshrc and the
> executes .xinitrc (trivial, isn't it?) to control how the startuo
> of your xsession will go.
> Make sure both files (.xinitrc and .xsession) are +x attribute.
>> Keep getting this console error message hundreds of times
>> init: getty repeating too quickly on port /dev/ttyv8, sleeping 30 second
> Hey, I saw this one... but I'm not sure how I solved it. Is your
> /etc/hosts and hostname set correctly? I think it was something
> like this, something I would never had put in any combination
> with X...
> By the way, in order to try if xdm is working correctly it can be
> started directly by the command "xdm" anytime.

I had ~/.xsession spelled correctly in the directory. Just typo error in 
email. Changed the contents of ~/.xsession as you posted. Still no joy.
/etc/hosts file is correct.

Running release 7.0. When i enter xdm on command line of root nothing 
happens. ps ax command shows no xdm running.

Still getting error msg
init: getty repeating too quickly on port /dev/ttyv8, sleeping 30 second

More information about the freebsd-questions mailing list