Openoffice 3.0.0 - spellchecker not functioning

Nikola Lečić nikola.lecic at
Fri Nov 7 13:05:56 PST 2008

Hash: RIPEMD160

On Fri, 07 Nov 2008 14:17:25 +0000
Craig Butler <craig001 at> wrote:
> On Thu, 2008-11-06 at 18:13 +0000, Mike Clarke wrote:
> > I've installed from ports on my 6.4-RC1 
> > system. The install, using the command  
> > portinstall  -m "LOCALIZED_LANG=en-GB -DWITH_KDE" 
> > editors/, appeared to complete OK and I can 
> > run /usr/local/bin/ but attempts to
> > check spelling in a document with known spelling errors always fail
> > to find any errors.
> > 
> > The "Available language modules" section in Tools - Options -
> > Language Settings - Writing Aids" is empty, unlike my copy of
> > Openoffice 2.3 which has 3 entries in this section.
> > 
> > Should the language modules have been installed or have I missed 
> > anything when installing the port?
> > 
> Hi Mike,
> Don't think ya missed anything, I am in the same boat...
> I also compiled with the LOCALIZED_LANG=en-GB flag.
> Anybody with a solution ? my spelling isn't that good so would need to
> spell check my documents.

I have, i.e.
compiled with

  'editors/openoffice*' => [

on FreeBSD 7.1-PRERELEASE #0: Sun Oct 12 (i386) and I have all 3
sections in Tools -> Options -> Language Settings -> Writing Aids.

The dictionaries page says:

	IMPORTANT NOTE: From 3.0 on the dictionary wizard
	is not longer available -- Dictionaries are now available via
	the extensions repository.


So, the users are supposed to download .oxt files and
run them. However, I experienced the 'bad transfer url' problem with all
extension files; this was reported on FreeBSD mailing lists in the past
with no available solution.

Happily, the instruction from the same page (DictOOo-Wizard, intended
for worked just fine in my OpenOffice-3. I downloaded

and it worked like a charm, installing Hunspell Spellchecker module and
dictionary files.

Hope this helps.

- -- 
Nikola Lečić = Никола Лечић
fingerprint : FEF3 66AF C90E EDC3 D878  7CDC 956D F4AB A377 1C9B
Version: GnuPG v2.0.9 (FreeBSD)


More information about the freebsd-questions mailing list