error mounting USB disk: Invalid argument

Roland Smith rsmith at
Sat May 31 07:30:03 UTC 2008

On Sat, May 31, 2008 at 08:25:22AM +0200, Colin Brace wrote:
> Hi all,
> I am having difficulties mounting a USB drive under 7.0-STABLE. Running
> sysinstall, I can create a partition and format it. But sysinstall is
> unable to mount it:
> Error mounting /dev/da0s1d on /media/disk6 : Invalid argument
> The same error ocurrs when I try to mount it manually on the command line.
> I have tried various mount points, to no avail. 
> Anyone have any ideas what is going wrong?

Can you show us what is shown in the dmesg output when you plug this
drive in, which devices are then created and the exact command that you
used to mount it?

[plain text _non-HTML_ PGP/GnuPG encrypted/signed email much appreciated]
pgp: 1A2B 477F 9970 BA3C 2914  B7CE 1277 EFB0 C321 A725 (KeyID: C321A725)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list