External USB disk won't mount

Chuck Robey chuckr at telenix.org
Wed May 28 18:45:41 UTC 2008

Hash: SHA1

Mark Ovens wrote:
> Bought an external USB HD enclosure but it doesn't work under FreeBSD.
> Under FreeBSD-6.3-STABLE:
> umass0: Super Top USB 2.0  IDE DEVICE, rev 2.00/2.01, addr 2
> da2 at umass-sim0 bus 0 target 0 lun 0
> da2: <MAXTOR 6 L040J2 \0000\0000> Fixed Direct Access SCSI-0 device
> da2: 40.000MB/s transfers
> da2: 38172MB (78177792 512 byte sectors: 255H 63S/T 4866C)
> # mount /dev/da2s1f /mnt
> # ls /mnt

I saw a mail yesterday about something nearly like this, from nej, except with
him, the umass device wasn't reporting anything at all, no device when he
plugged it in.  I sent him a little piece of usb driver code that resets his usb
buss, just to experiment and see if that got his devices correctly detected, but
he didn't yet reply, I don't know if it worked for him.  I don't have something
like that to experiment with.

With yours, you obviously have a da2 ... that only means you have a
direct-access disk devide #2 being detected.  The next step is to figure oout
what kind of formatting you have.  Hopefully, it's been fdisk'ed to where it has
partitions, so do this (as root): "/sbin/fdisk /dev/da2", and in fdisk, give the
'p' command, this will print out the formatting for any partitions.  Likely it's
either one of the various Microsoft things, or a Linux one, or even a FreeBSD
one.  Depending on what you see, you either directly give a mount command next,
to the right partition, or maybe you use bsdlable to find out what the
disk-labelling is (if it's a FreeBSD disk).

Probably the right thing to do is to reply here with the results of the fdisk,
then whoever jumps on it first can give you the right thing to do next.  I'm not
going to try to tell you all the possible ways to go at this point, not without

> #
> (The disk is from another FreeBSD system so is UFS2 and da2s1f is /usr
> on the other system)
> So although it mounts, nothing is visible.
> After a few minutes this happens:
> umass0: at uhub3 port 1 (addr 2) disconnected
> (da2:umass-sim0:0:0:0): lost device
> (da2:dead_sim0:0:0:0): Synchronize cache failed, status == 0x8, scsi
> status == 0x0
> (da2:dead_sim0:0:0:0): removing device entry
> umass0: detached
> Tried it under 7.0-RELEASE and it's even worse - it crashes the kernel with
> Fatal Trap 12: page fault in kernel mode. (forget the exact wording of
> the message, but it's definitely Fatal Trap 12).
> So is this just a case of the device not complying with USB standards -
> the manufacturer just tests it under Windows and that's good enough - or
> is there a way to solve this?
> I can confirm that the disk is good as I borrowed another enclosure to
> try and that works as expected.
> Regards,
> Mark
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscribe at freebsd.org"

Version: GnuPG v2.0.4 (FreeBSD)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the freebsd-questions mailing list