ntpd - I'm sure I'm setting it up wrong, but I can't figure out how.

Chuck Swiger cswiger at mac.com
Mon May 26 18:02:57 UTC 2008

On May 26, 2008, at 10:02 AM, Jim Stapleton wrote:
> I'm trying to run ntpd to auto-update my computer's time (since I'm
> not supposed to use ntpdate).
> /etc/ntp.conf (I've tried without the restrict line):
> ========================================
> server sushi.lyon.edu
> restrict default ignore
> driftfile /var/db/ntp.drift
> ========================================

Your configuration is blocking all NTP traffic and commands, even from  
localhost.  See:


You also want to configure at least 4 timeservers if you want to get  
reliable "falseticker" detection; see:


> I have tried this command (with and without the -g), with no success.
> If I don't have an /etc/ntp.conf, it complains, and it stops
> complaining when I put /etc/ntp.conf back where it belongs:
> $ sudo  /usr/sbin/ntpd -q -g -f /var/db/ntpd.drift -l /var/log/ 
> ntpd.log

The system knows how to do this:

   echo 'ntpd_enable="YES"' >> /etc/rc.conf
   /etc/rc.d/ntpd start                       # or restart, perhaps


More information about the freebsd-questions mailing list