ipw2200 freebsd 7 firmware problem

Fernando Apesteguía fernando.apesteguia at gmail.com
Tue May 20 21:17:59 UTC 2008

Hi all,

I have an ipw2200 bg. I can't make it work under FreeBSD 7 on AMD64.

This is the output of pciconf -lv

none0 at pci0:0:5:0:       class=0x028000 card=0x27028086 chip=0x42208086
rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'MPCI3B  driverIntel PRO/Wireless 2200BG'
    class      = network

dmesg shows the following:

pci0: <network> at device 5.0 (no driver attached)

I tried to instal the iwi-firmware from ports:

===>  iwi-firmware-2.4_8 is configured with iwicontrol(8) which you
don't need, use 'make rmconfig' and uncheck CONTROL.
*** Error code 1

Stop in /usr/ports/net/iwi-firmware.

I tried the suggested workaround, but I got:

===> No user-specified options configured for iwi-firmware-2.4_8

I tried with pkg_add -r iwi-firmware-2.4_8 and I got

Error: FTP Unable to get
File unavailable (e.g., file not found, no access)
pkg_add: unable to fetch
by URL

My ports are up to date (cvsup.de.FreeBSD.org)

So... How can I make the wireless card work?

Any help is appreciated. Thanks in advance.

More information about the freebsd-questions mailing list