vge(4) driver not working at 1G speeds

Stuart Fraser stuart at
Mon Mar 31 09:21:20 PDT 2008

I'm trying to a Via Velocity Gigabit Networking driver vge(4) to work at
1000baseTX on a Via EPIA SN18000 Motherboard.

It will always Auto negotiation backoff to 100MB Full duplex, which works
perfectly. When I try to manually force the card 1000baseTX the interface
status reports 'no carrier' and I can get not connectivity. I have tried
Ubuntu live disk and it works seamlessly to 1GB, so I'm sure the
cabling/switch etc is fine.

So I have tried 1000baseTX full and half duplex. I have tried to disable the
hardware handoff using the mediaopt commands -rxcsum and -txcsum. Further I
have tried to use the link0 operation as described in the man page but I

nas# ifconfig vge0 mediaopt link0
ifconfig: SIOCSIFMEDIA (media): Device not configured

Further I have tried Release 7.0 and Stable 7 with the vge driver compiled
in also as an external module loaded through loader.conf and lastly waiting
until a full boot has completed and manually loading the if_vge module.

The only thing I can see is that the chipset is actually a VT6130 and
perhaps the driver needs 'tweaked' or there is some sysctl somewhere to poke
it into life. As I say it works fine in 100MB mode and I can use 100M for a
while but I'm planning on using this as a NAS so 1G would be preferred.

Any help, suggestions, thoughts would be appreciated.


More information about the freebsd-questions mailing list