not found

Kris Kennaway kris at
Mon Mar 31 05:21:46 PDT 2008

Niels Kobschaetzki wrote:
> Hi!
> I have here severe problems with installing stuff. I tried to
> recompile xemacs 21.4 and got a:
> /libexec/ Shared object "" not found, required by
> "install-info"
> I searched google and it seems that this is from FreeBSD 6 while I am
> running 7 and I have only on my system.
> I wondered, tried to compile xemacs 21.5 from the sources and ran into
> some other trouble. I figured that I'll do a a cvsup with FreeBSD
> 7.0-stable and do a portupgrade -ra to do an upgrade for all packages;
> hoping that the trouble wents away and I get some kind of xemacs with
> mule-support installed. But the portupgrade ran into some problems
> because of a stale dependency (ORBit2-2.14.10 -> libIDL-0.8.9_1
> (devel/libIDL).
> I want to install now this stale dependency and get the same error:
> /libexec/ Shared object "" not found, required by
> "install-info"
> Anyone who can help here?

I guess you missed part of the upgrade steps when you updated to 7.0. 
The step you missed involved a portupgrade -fa (or -faP) to refresh all 
of your ports with 7.0 versions to avoid precisely this problem.  You 
should do that now to repair your system.


More information about the freebsd-questions mailing list