problems with i386 jail on amd64 install 7.0 Release

Kris Kennaway kris at
Fri Mar 28 13:51:04 PDT 2008

Mark Moellering wrote:
> On Friday 28 March 2008 03:27:27 pm you wrote:
>> Mark Moellering wrote:
>>> On Friday 28 March 2008 06:23:49 am Kris Kennaway wrote:
>>>> Mark Moellering wrote:
>>>>> I have been trying to install an i386 jail on an amd64 install.  I
>>>>> added Target=i386 to the command line in the make buildworld and
>>>>> installworld commands.  I keep getting the following (or similar) error
>>>> 'Target' does nothing, there is no such variable.  If you meant
>>>> 'TARGET', that is a real variable but not the one you want.  You need to
>>>> add 'TARGET_ARCH=i386' to your build/installworld to successfully
>>>> cross-compile.
>>>> Kris
>>> Kris,
>>> Thanks for the reply.
>>> I aplogize, I should have been more explicit.
>>> I tried TARGET=i386 ; TARGET_ARCH=i386; and both together, all gave the
>>> same error.
>>> (/libexec/ Shared object "" not found, required
>>> by "sh")
>>> Have you or has anyone else on the list successfuly done this?
>> Yes, frequently.  Does the library exist in the chroot and is it an i386
>> library (use file(1))?
>> Kris
> Thanks Kris, you're a lifesaver.
> The response I get using File is:
> ELF 32-bit LSB shared object, Intel 80386, version 1 (FreeBSD), 
> dynamically linked, stripped

OK, that is correct.  Is the rest of the chroot configured properly, 
e.g. did you populate /etc and /var?


More information about the freebsd-questions mailing list