hplip setup problems

Isaac Mushinsky itz at mushinsky.net
Wed Mar 26 19:15:16 PDT 2008

On Wednesday 26 March 2008 00:21:12 Isaac Mushinsky wrote:
> I am close to assasinating my HP Photosmart C4280 in frustration.
> 1. This is an all-in-one device. (I did not try the scanner setup yet)
> 2. ulpt, umass, uscanner modules are not in kernel and not kld-loaded.
> 3. Machine is FreeBSD 7-stable/amd64.
> 4. hplip is 2.8.2
> $ usbdevs
> addr 1: UHCI root hub, Intel
> addr 1: UHCI root hub, Intel
> addr 1: UHCI root hub, Intel
> addr 1: EHCI root hub, Intel
>  addr 2: Photosmart C4200 series, HP
> addr 1: UHCI root hub, Intel
> addr 1: UHCI root hub, Intel
> addr 1: UHCI root hub, Intel
> addr 1: EHCI root hub, Intel
> There is a ppd file for these series with the hplip distribution.
> hpssd, cups started in the order needed. hp-setup detects the printer, and
> then says 'Unable to create queue'. CUPS web interface actually adds the
> printer, but then cannot print test page to it. cups user runs hpssd (I
> tried root too).
> /var/log/messages has:
> Mar 25 23:57:56 omsk python: io/hpmud/musb.c 135: unable
> get_string_descriptor -5: Input/output error Mar 25 23:57:56 omsk python:
> io/hpmud/musb.c 1951: invalid serial id string ret=-5
> Here is all relevant output:
> http://omsk.mushinsky.net/hplip-trouble
> Any help is appreciated. Thanks.
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscribe at freebsd.org"

final piece of information: sane cannot open the HP all-in-one as a scanner 
with same error (getting serial id). However, my Nikon LS40-ED (a 35mm film 
scanner) works fine. So the problem is apparently not my installation or 

~> sane-find-scanner 

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure 
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04b0 [Nikon], product=0x4000 [LS-40 ED]) at 
found USB scanner (vendor=0x03f0 [HP], product=0x5c11 [Photosmart C4200 
series]) at libusb:/dev/usb3:/dev/ugen0
  # Your USB scanner was (probably) detected. It may or may not be supported 
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.

The Nikon scanner works, the HP device fails to return serial id as above.

More information about the freebsd-questions mailing list