MPlayer does not compile (actually gio-fam-backend does not)

mdh mdh_lists at
Tue Mar 25 18:19:37 PDT 2008

--- Andriy Babiy <freebsdathome at> wrote:

> > I'm trying to compile MPlayer but it just doesn't
> work because it
> > depends on gio-fam-backend and that does not
> compile. It always stops
> > with:
> > /usr/bin/ld: cannot find -lgio-2.0
> > gmake: *** [] Error 1
> > *** Error code 2
> > 
> > Stop in /usr/ports/devel/gio-fam-backend.
> > *** Error code 1
> > 
> > Any ideas what I can do?
> > 
> > Niels

I ran into this issue as well.  It seems to have more
to do with a change to the gio-fam-backend port
requiring something recently added to the glib port. 
This bug happened to me with glib 2.14 and I fixed it
by upgrading to glib 2.16 which is the version the
glib20 port currently installs.  This change in the
port must have happened recently, like in the past few

The fix is to upgrade your devel/glib20 port to the
latest, and then go for the gio-fam-backend port.  

> What does the output of uname and objformat look
> like?

This happened to me on 7.0-S, but I'd imagine it
probably occurs everywhere.  
I'd guess that libgio is a part of the glib20 port
that was not installed by 2.14 but is by 2.16. 
gio-fam-backend should probably do a dependency check
for it and if it isn't there, should upgrade

Be a better friend, newshound, and 
know-it-all with Yahoo! Mobile.  Try it now.;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ

More information about the freebsd-questions mailing list