junk in remote mutt

Chad Perrin perrin at apotheon.com
Tue Mar 25 06:50:19 UTC 2008

On Mon, Mar 24, 2008 at 11:32:24PM -0700, Bill Campbell wrote:
> On Tue, Mar 25, 2008, Chad Perrin wrote:
> >On Tue, Mar 18, 2008 at 07:23:43AM +0300, Yuri Pankov wrote:
> >> On Mon, Mar 17, 2008 at 04:03:54PM -0600, Chad Perrin wrote:
> >> > I'm not sure that's a very good title for this email, but it's what I've
> >> > got.
> >> > 
> >> > Since configuring my environment to use UTF-8, I've had a problem while
> >> > checking email on a server.  I log into the server via SSH, then enter
> >> > the `mutt` command.  As I page through the inbox, open and close emails,
> >> > et cetera, I get a bunch of junk on the screen -- characters from the
> >> > previous screen appearing on the current screen.  I have to use Ctrl + L
> >> > to clear it up and return the appearance of the screen to the way it's
> >> > supposed to look.
> >> > 
> >> > What can I do to eliminate this problem?  I don't want to have to force a
> >> > screen redraw every time I switch between views, scroll down a page in
> >> > mutt, and so on.  I also don't want to go back to a character set limited
> >> > to plain ol' ASCII (there's a reason I use rxvt-unicode instead of rxvt).
> >> 
> >> Don't see it here. If you are sure that mutt uses UTF-8 charset (ie,
> >> forced it with 'set charset="utf-8"'), make sure it's linked against
> >> ncursesw library (and not just ncurses) - need to use WITH_NCURSES_PORT
> >> on 6.2 and earlier or build it using WITH_SLANG.
> >
> >I finally got around to checking the settings in the Makefile and
> >recompiling mutt.  End result: same problem.  If anyone else has any
> >ideas what might be causing this problem, please let me know.
> >
> >addendum: The computer I'm using as a client to access mutt on another
> >machine doesn't have this same problem locally.  When I open a local mutt
> >instance, there's no junk on the screen.  I decided to try using SSH
> >through the remote system where I'm encountering this issue, then from
> >there using SSH to get back to the local machine, and opened mutt inside
> >this contrived SSH loop.  Still no problem.  Thus, whatever the problem
> >is seems to be particular to the remote machine.
> >
> What is your TERM environment variable setting?  Are the terminfo
> files on the remote system current?

The TERM environment variable on both systems is set to `rxvt`.  I'm not
sure what I should be looking for to be sure the terminfo file is

> I'm reasonably sure that mutt uses ncurses, and if it is not
> built correctly, that could also cause problems.

I have tried both the default (WITH_SLANG=yes) and WITH_NCURSES_PORT=yes
on the remote system.  Otherwise, I haven't mucked about with the
Makefile of mutt at all.

CCD CopyWrite Chad Perrin [ http://ccd.apotheon.org ]
Brian K. Reid: "In computer science, we stand on each other's feet."

More information about the freebsd-questions mailing list