X.org 7.3 sure is a mess...

Scott Bennett bennett at cs.niu.edu
Mon Mar 24 18:04:27 PDT 2008

     On Wed, 19 Mar 2008 19:01:28 +0000 Mark Ovens <parish at magichamster.com>
>Peter Boosten wrote:
>> Ken Gunderson wrote:
>>> [snip]
>>>> Looks like you're having a problem with your window manager, instead of 
>>>> Xorg.
>>>> Mine (with enlightenment-devel) works like charm. None of the issues
>>>> you describe anyway.
>>>> Peter
>>> So how would you explain that I am seeing same type of behaviors in
>>> straight "startx" with default twm, i.e. bundled Xorg wm?
     I'm using WindowMaker (wmaker).  Firefox hangs something in a way that
I can't get any response whatsoever from the keyboard, touchpad, keyboard
pointer thingy that looks like a pencil eraser, or trackball.  Because I have
no other box from which to log in remotely, my only option is to power the
system down, turn it back on, reboot, wait for fsck, etc.  Many xscreensaver
modules cause the *server*, not the window manager, to die on a signal 11.
>> Dunno. But the troubles cannot originate from the xorg ports, or 
>> everyone would see the same behaviour, right?
> > Maybe some other port, or hardware (maybe your video card? - just
> > guessing), or the driver for that particular piece of hardware.
> >
>One would expect so, but it would appear not to be the case. I'm having 
>the same problem - if I ssh in from another box I see the Xorg process 
>sucking >100% CPU and the state is *GIANT
>I'm using an ATI card but people are having the same issue with nVidia 
>and Matrox cards. My box has run every version of Xorg since it replaced 
>XFree86 on FreeBSD and many versions of XFree86 before that without this 

     Mine is a Mobility Radeon 9800.
>Also, the problem seems to come and go for me as I update my ports, i.e. 
>the box has the problem, I run ``portmaster -a'' and the problem goes 
>away. sometime later I run ``portmaster -a'' again and the problem 
>re-appears. Only seems to happen when X-related stuff gets updated.

     I haven't noticed the intermittency you describe here, but that is
likely due to the fact that updating the various parts of X and X applications
takes so long that I try to avoid doing it very often.
>The other thing I've noticed is, on my box at least, that the problem 
>always starts when I move the mouse (not every time of course) so could 
>it be Xorg 7.3 not playing nicely with the mouse driver - or the USB 
>driver since my mouse is a USB one? Which may explain why some people 
>see the problem and others don't?

     That's a thought.  The Firefox problem always seems to occur when I
make the first button click anywhere in the Firefox window, but maybe I should
try simply moving the cursor into the window and wait a few seconds to see
what happens before pressing a button.
>This is really becoming a big PITA.
     I concur.  Since the "upgrade"--downgrade is more like it--to 7.3 from
6.9, I only have access to a functioning web browser when I shut down FreeBSD
and boot Windows XP, a very sad state of affairs.

                                  Scott Bennett, Comm. ASMELG, CFIAG
* Internet:       bennett at cs.niu.edu                              *
* "A well regulated and disciplined militia, is at all times a good  *
* objection to the introduction of that bane of all free governments *
* -- a standing army."                                               *
*    -- Gov. John Hancock, New York Journal, 28 January 1790         *

More information about the freebsd-questions mailing list