R: Various X errors (difficult to see)

Luca Presotto Luca.Presotto at cern.ch
Fri Mar 21 10:54:57 PDT 2008

>>Is it something wrong in /etc/hosts??

>It could be your /etc/hosts or /etc/hosts.allow or you may need to add:
> -listen_tcp

>to your startx commandline.

I supposed the problem was there! I'll look at -listen_tcp and at hosts.allow.
I have doubts about setting hosts. X used to give me errors about not being able to connect (but still worked!). Then I tried to set up hosts correctly and now here's the new "problem".
I've read "man hosts", read the handbook and googled around but it's not very clear what I should write in this file.
My hostname is lucy. It's a laptot that eventually connects to the nearest available network. So it isn't part of a domain or something like that.
In the end I set up the concerned hosts lines to:
::1 localhost localhost.my.domain lucy localhost localhost.my.domain lucy
Is it correct?
Why should I leave localhost.my.domain ?

>These messages are errors telling you the window manager cannot manage these mimetypes.  
>Did you remove any ports for handling these types of archive files?

No, I didn't remove anything! But I copied just 3 warnings. There were 130 of them related not only to archive files handling but almost to everything.

>This error refers to the artsd daemon already running, or the system thinks this daemon is running.  You should open a terminal window and do:
>ps -ax|grep -i art

>and see if the artsd daemon is running or not.  If it is not, you may need to force it to start.

I'll try that later!

>When you say "every time you launch a program"  how exactly are you trying to launch a program?  

Either with the kde "launch program", either launching the file in a xterm, either when firefox opens a new popup....And I think those are pretty much all the possible ways I explored!

More information about the freebsd-questions mailing list