X.org 7.3 sure is a mess...

Norberto Meijome freebsd at meijome.net
Thu Mar 20 14:00:03 UTC 2008

On Wed, 19 Mar 2008 19:01:28 +0000
Mark Ovens <parish at magichamster.com> wrote:

> Peter Boosten wrote:
> > Ken Gunderson wrote:
> >> [snip]
> >>> Looks like you're having a problem with your window manager, instead of 
> >>> Xorg.
> >>>
> >>> Mine (with enlightenment-devel) works like charm. None of the issues
> >>> you describe anyway.
> >>>
> >>> Peter
> >> 
> >> So how would you explain that I am seeing same type of behaviors in
> >> straight "startx" with default twm, i.e. bundled Xorg wm?
> >> 
> > 
> > Dunno. But the troubles cannot originate from the xorg ports, or 
> > everyone would see the same behaviour, right?
> > 
>  > Maybe some other port, or hardware (maybe your video card? - just
>  > guessing), or the driver for that particular piece of hardware.
>  >
> One would expect so, but it would appear not to be the case. I'm having 
> the same problem - if I ssh in from another box I see the Xorg process 
> sucking >100% CPU and the state is *GIANT

I would very much like to see a process using "> 100% CPU" :)

What CPU ? I haven't seen GIANT on Xorg for a while...but, again, I don't check
all the time :d

anyway... my xorg sits at 7.81% on select...i've been on this session for 17
hours, and have a heavily loaded xfce session with 10 virt desktops. I actually
recently removed the lower limit for cpufreq to drop the freq and i've been
hovering @ 200 Mhz (measured once a second in gkrellm), although right now I'm
between 800 and 1000 Mhz.

could you please send your xorg.conf ? 

have you tried attaching ktrace to xorg in those situations and seeing what it
is doing ? 
what about other system vitals ? is your disk trashing ? RAM usage? 

> I'm using an ATI card but people are having the same issue with nVidia 
> and Matrox cards. My box has run every version of Xorg since it replaced 
> XFree86 on FreeBSD and many versions of XFree86 before that without this 
> problem.
> Also, the problem seems to come and go for me as I update my ports, i.e. 
> the box has the problem, I run ``portmaster -a'' and the problem goes 
> away. sometime later I run ``portmaster -a'' again and the problem 
> re-appears. Only seems to happen when X-related stuff gets updated.

maybe if you can pinpoint WHAT gets updated it would be of more help :)

the ati drivers had several updates over the last few months...

> The other thing I've noticed is, on my box at least, that the problem 
> always starts when I move the mouse (not every time of course) so could 
> it be Xorg 7.3 not playing nicely with the mouse driver - or the USB 
> driver since my mouse is a USB one? Which may explain why some people 
> see the problem and others don't?

I'd like to see a count of hands ... who DOESN'T use USB mice or
built-in-mice-in-laptops nowadays...

by any chance you wouldn't have the xcomposite extension enabled... ? 

> This is really becoming a big PITA.

i understand, but without concrete information it wont go anywhere fast :)

{Beto|Norberto|Numard} Meijome

"He loves nature in spite of what it did to him."
  Forrest Tucker

I speak for myself, not my employer. Contents may be hot. Slippery when wet.
Reading disclaimers makes you go blind. Writing them is worse. You have been

More information about the freebsd-questions mailing list