ndis0 no link on 6.3-RELEASE

Glen Barber glen.j.barber at gmail.com
Sun Mar 16 16:42:37 UTC 2008

Ted Mittelstaedt said: 
>   I just setup my laptop with a wireless card a couple weeks
> ago and FreeBSD 6.3-RELEASE.  (it's an older Toshiba)
>   I went through a total of 5 different wireless cards before
> I found one that I was able to get working ndis drivers from
> ndisgen.  Fortunately there's a used computer place near here
> (freegeek.org) that had a box of pcmcia wireless cards of all
> different makes and models, which kindly allowed me to plunk
> down my laptop  (which dual-boots between Windows 98 and FreeBSD)
> and they have wireless.  So I would pick a card out of their bin,
> boot into Windows, download the Windows driver, make sure the
> card worked under Windows, then boot into FreeBSD and mount
> the Windows partition, copy over the Windows driver and inf
> file to the FreeBSD side, run ndisgen and then try loading the
> driver.
> With some cards, the driver wouldn't even activate the card.
> With other cards, the driver would allow me to list the wireless
> nodes then panic the system when I tried associating.
> The card that did work was a Realtek-based card.  And, it did
> not work with the most current Windows drivers from the Realtek
> website, it worked with the Windows drivers that were from a couple
> years ago.  (I found this out quite by accident)
> Fortunately, they DID also have a number of the Wavelan
> cards - these are supported natively with the wi0 driver -
> that worked out of the box.  Those cards are only 802.11b
> though so I kept at it with ndisgen and the newer cards.
> The interesting thing is that the original wireless card I
> had in the Toshiba - a Texas Instruments-based chipset model -
> never really quite worked properly in the Toshiba under Windows.
> I put it into a different laptop I owned - a Thinkpad, and
> it worked great in that.
> Unfortunately, in your case, nothing has changed with ndisgen
> since 2006 (see http://www.freebsd.org/cgi/cvsweb.cgi/src/usr.sbin/ndiscvt/ )
> so it's not that, it's something else in the system that changed.
> Start with the basics.  Copy your bcmwl5.ko into /boot/modules
> then in loader.conf put bcmw15_load="YES" and reboot the system,
> check dmesg, and see if it's even loading
> Next put in /etc/rc.conf  "ifconfig_ndis0="inet ssid myssid"
> and see if it even comes up at all and you can ping out (obviously
> you will have to temporairly turn off wpa on your wireless node,
> set the correct ssid, and set the correct IP address to hard-code an
> IP address)
> If that doesen't work, regen the bcmw15.ko file using the "old"
> method:
> # cp foo.sys foo.inf /sys/modules/if_ndis
> # cd /sys/modules/ndis
> # make; make load
> # cd /sys/modules/if_ndis
> # ndiscvt -i foo.inf -s foo.sys -o ndis_driver_data.h
> # make; make load
> You need to isolate the problem to see if the driver is simply
> just not working at all under 6.3, or if it is working, but it's
> a scripting or turnup out of sequence error.  And you need to
> see if wpa has anything to do with it.

Hi Ted. Thanks for the reply.

Unfortunately, until I either get time to resize my hard disk and add a
separate freebsd installation, or I figure out  how to undo a
buildworld, looks like I'm stuck.  It's my school laptop, so I kind of
need to get work done. ;)  (I am able to run a 6.3-RELEASE kernel, but
the 'world' is 6.3-RC1.)

Regarding older drivers:  Yes,  I had this problem with my current
chipset in 6.2-RELEASE.  This is why I was so surprised I had problems
with 6.3-RELEASE. 

Either way, I appreciate your response. 

Glen Barber

More information about the freebsd-questions mailing list