HDD missing from sysinstall

Troels Kofoed Jacobsen tkjacobsen at gmail.com
Sun Mar 16 16:39:16 UTC 2008

> When I put in my fbsd 6.3 or 7.0 install disk sysinstall is unable to
> detect any of the hard drives in my computer.
> This is includes SATA and IDE HDDs in varying orders.   BIOS is able
> to detect the the hard drives.   I Previously had fbsd 6.2 installed
> on them and the problem started when I upgraded the kernel to 6.3
> although I don't see my upgrades relevance as I have tried to
> reinstall from a clean disk since then.

I have the exact same problem on an Asus P5N-E sli board. I have two ide harddrives, two ide optical drives and one sata harddisk connected. After trying to boot FreeBSD 7.0, which gives me "No disks found", i cannot boot in freebsd 6.2 or linux anymore. I have to reboot with the ide harddisks disconnected. And then erboot again (with drives reconnected) before my machine can boot again. (Then both freebsd 6.2 and linxu works again)

This is not a problem in the installer but in the kernel as i get the same result when upgrading (both to 7.0 and 8.0-current)

I thing thes is a very severe problem/bug/regression.. I dont dare to try FreeBSD on a laptop where i cannot disconnect the drives as easily.

dmesg from 6.2 attached. I cannot find a way to provide dmesg from 7.0 from the install cd (disk 1 -- i cannot mount livefs as optical drives are also not found)

Best Regards

Troels Kofoed Jacobsen
tkjacobsen at gmail.com
tel: +45 20880798
-------------- next part --------------
Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.2-RELEASE #0: Fri Jan 12 11:05:30 UTC 2007
    root at dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/SMP
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz (2400.02-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x6f6  Stepping = 6
  AMD Features=0x20100000<NX,LM>
  AMD Features2=0x1<LAHF>
  Cores per package: 2
real memory  = 2146369536 (2046 MB)
avail memory = 2095267840 (1998 MB)
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
ioapic0: Changing APIC ID to 4
ioapic0 <Version 1.1> irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: <Nvidia ASUSACPI> on motherboard
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi0: Power Button (fixed)
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pci0: <memory, RAM> at device 0.1 (no driver attached)
pci0: <memory, RAM> at device 0.2 (no driver attached)
pci0: <memory, RAM> at device 0.3 (no driver attached)
pci0: <memory, RAM> at device 0.4 (no driver attached)
pci0: <memory, RAM> at device 0.5 (no driver attached)
pci0: <memory, RAM> at device 0.6 (no driver attached)
pci0: <memory, RAM> at device 0.7 (no driver attached)
pci0: <memory, RAM> at device 1.0 (no driver attached)
pci0: <memory, RAM> at device 1.1 (no driver attached)
pci0: <memory, RAM> at device 1.2 (no driver attached)
pci0: <memory, RAM> at device 1.3 (no driver attached)
pci0: <memory, RAM> at device 1.4 (no driver attached)
pci0: <memory, RAM> at device 1.5 (no driver attached)
pci0: <memory, RAM> at device 1.6 (no driver attached)
pci0: <memory, RAM> at device 2.0 (no driver attached)
pci0: <memory, RAM> at device 2.1 (no driver attached)
pci0: <memory, RAM> at device 2.2 (no driver attached)
pcib1: <ACPI PCI-PCI bridge> at device 3.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
pcib2: <ACPI PCI-PCI bridge> at device 5.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 6.0 on pci0
pci3: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> at device 7.0 on pci0
pci4: <ACPI PCI bus> on pcib4
atapci0: <JMicron JMB360 SATA300 controller> port 0xdf00-0xdf07,0xde00-0xde03,0xdd00-0xdd07,0xdc00-0xdc03,0xdb00-0xdb0f mem 0xfd9fe000-0xfd9fffff irq 16 at device 0.0 on pci4
atapci0: AHCI Version 01.00 controller with 1 ports detected
ata2: <ATA channel 0> on atapci0
pci0: <memory, RAM> at device 9.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 10.0 on pci0
isa0: <ISA bus> on isab0
pci0: <serial bus, SMBus> at device 10.1 (no driver attached)
pci0: <memory, RAM> at device 10.2 (no driver attached)
ohci0: <OHCI (generic) USB controller> mem 0xfe02f000-0xfe02ffff at device 11.0 on pci0
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 8 ports with 8 removable, self powered
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xfe02e000-0xfe02e0ff at device 11.1 on pci0
usb1: EHCI version 1.0
usb1: companion controller, 8 ports each: usb0
usb1: <EHCI (generic) USB 2.0 controller> on ehci0
usb1: USB revision 2.0
uhub1: nVidia EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub1: 8 ports with 8 removable, self powered
atapci1: <nVidia nForce MCP51 UDMA133 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xfd00-0xfd0f at device 13.0 on pci0
ata0: <ATA channel 0> on atapci1
ata1: <ATA channel 1> on atapci1
atapci2: <nVidia nForce MCP51 SATA300 controller> port 0x9f0-0x9f7,0xbf0-0xbf3,0x970-0x977,0xb70-0xb73,0xf800-0xf80f mem 0xfe02d000-0xfe02dfff irq 20 at device 14.0 on pci0
ata3: <ATA channel 0> on atapci2
ata4: <ATA channel 1> on atapci2
atapci3: <nVidia nForce MCP51 SATA300 controller> port 0x9e0-0x9e7,0xbe0-0xbe3,0x960-0x967,0xb60-0xb63,0xf300-0xf30f mem 0xfe02c000-0xfe02cfff irq 21 at device 15.0 on pci0
ata5: <ATA channel 0> on atapci3
ata6: <ATA channel 1> on atapci3
pcib5: <ACPI PCI-PCI bridge> at device 16.0 on pci0
pci5: <ACPI PCI bus> on pcib5
fwohci0: <VIA Fire II (VT6306)> port 0xbf00-0xbf7f mem 0xfdbff000-0xfdbff7ff at device 8.0 on pci5
fwohci0: OHCI version 1.10 (ROM=1)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:11:d8:00:01:26:eb:74
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:11:d8:26:eb:74
fwe0: Ethernet address: 02:11:d8:26:eb:74
fwe0: if_start running deferred for Giant
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
pci0: <multimedia> at device 16.1 (no driver attached)
nve0: <NVIDIA nForce MCP13 Networking Adapter> port 0xf200-0xf207 mem 0xfe02b000-0xfe02bfff irq 23 at device 20.0 on pci0
nve0: Ethernet address 00:1a:92:63:18:e7
miibus0: <MII bus> on nve0
ukphy0: <Generic IEEE 802.3u media interface> on miibus0
ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
nve0: Ethernet address: 00:1a:92:63:18:e7
acpi_tz0: <Thermal Zone> on acpi0
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
ppc0: <Standard parallel printer port> port 0x378-0x37f irq 7 on acpi0
ppc0: Generic chipset (EPP/NIBBLE) in COMPATIBLE mode
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model MouseMan+, device ID 0
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xd0000-0xd3fff,0xd4000-0xd5fff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
uhub2: Cypress Semiconductor Combi keyboard Hub ref design V1.74, class 9/0, rev 1.10/0.01, addr 2
uhub2: 2 ports with 2 removable, bus powered
ums0: SONY USB Mouse, rev 1.10/2.00, addr 3, iclass 3/1
ums0: 5 buttons and Z dir.
Timecounters tick every 1.000 msec
ad0: 156334MB <Maxtor 6Y160P0 YAR41BW0> at ata0-master UDMA133
ad1: 78167MB <Maxtor 6Y080L0 YAR41BW0> at ata0-slave UDMA133
acd0: DMA limited to UDMA33, device found non-ATA66 cable
acd0: DVDR <LITE-ON DVDRW SHW-16H5S/LS0N> at ata1-master UDMA33
acd1: CDRW <LITE-ON CD-RW SOHR-5238S/4S03> at ata1-slave UDMA33
ad6: 238475MB <Seagate ST3250620AS 3.AAE> at ata3-master SATA150
SMP: AP CPU #1 Launched!
Trying to mount root from ufs:/dev/ad0s1a

More information about the freebsd-questions mailing list