System can not boot, seems can not find right partition after add new label

Kemian Dang dangkm at
Sat Mar 15 11:26:54 UTC 2008


A short story is:
When I boot my laptop, the screen tells me "invalida partition" and
then give me the prompt "default: 0:ad(0,a)/boot/kernel/kernel".
My FreeBSD / partition is at /dev/ad4s3a, so I tried
"4:ad(3,a)/boot/kernel/kernel", but without lucky.
Could someone tell me how should I give it the command, thanks in advance.

Long story:
Because my partition is nearly full, last night I delete a windows
ntfs partition and try to use it under FreeBSD 7.0 Release as /home, I
used to put /usr and /home together.

I can not remember whether I do something stupid, I just dd
if=/dev/zero of=/dev/ad4s2 to write zero, then when I want to use
bsdlabel to create new slice, but the new slice did not show up. So I
tried sysinstall, still did not work.
I thought it was because it used to be a ntfs partition, so I wanted
to boot to windows and delete the partition.
But it could not boot till now.

There used to be a easyBCD soft to help me boot freebsd from the
Windows Vista boot loader, but it did not appear, but a directly
Invalid Partition....

Any suggestion appreciated.

Best wishes,

More information about the freebsd-questions mailing list