portsnap errors

Wael Nasreddine mla at nasreddine.com
Fri Mar 14 17:43:11 UTC 2008

This One Time, at Band Camp, Brian <bri at brianwhalen.net> said, On Fri, Mar 14, 2008 at 09:59:26AM -0700:
> Anyone else seeing corrupt snapshot errors on the portsnap servers?  I 
> tried a couple times and got the below.  I didnt allow it to complete.
> Looking up portsnap.FreeBSD.org mirrors... 4 mirrors found.
> Fetching snapshot tag from portsnap3.FreeBSD.org... done.
> Fetching snapshot metadata... done.
> Updating from Thu Mar 13 06:10:47 PDT 2008 to Fri Mar 14 07:19:41 PDT 2008.
> Fetching 4 metadata patches. done.
> Applying metadata patches... done.
> Fetching 4 metadata files... gunzip: (stdin): unexpected end of file
> metadata is corrupt.
> Fetching 587 new ports or files... /usr/sbin/portsnap: cannot open 
> 1fcb6a83f53e20e2efc4dda71489275f065f73eed6c16dc422287ca081232112.gz: No 
> such file or directory
> snapshot is corrupt.
> Brian

I've had the same problem yesterday solved it with

mv /usr/ports /usr/ports-old
mv /var/db/portsnap /var/db/portsnap-old
portsnap fetch extract
mv /var/db/portsnap-old/distfiles/* /var/db/portsnap/distfiles/

You could probably remove the old folders later....

Wael Nasreddine
PGP: 1024D/C8DD18A2 06F6 1622 4BC8 4CEB D724  DE12 5565 3945 C8DD 18A2

.: An infinite number of monkeys typing into GNU emacs,
   would never make a good program. (L. Torvalds 1995) :.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20080314/82ee77e2/attachment.pgp

More information about the freebsd-questions mailing list