USB printer

Robert Marella rmarella at
Thu Mar 13 03:00:48 UTC 2008

On Wed, 12 Mar 2008 15:14:20 -0400
Chuck Robey <chuckr at> wrote:

> You know, while there are printing utils that actually work on
> FreeBSD, I can't personally recommend CUPS.  I keep on trying to get
> it to work on FreeBSD efvery year or so, then I need to go over to
> one of my other systems.  Last one I tried was an Epson Stylus C84,
> but I've also tried HP officejets, and I just can't get locally
> attached printers to work with cups.  I can get them to work with
> things like apsfilter very well, but either someone is going to have
> to fix the Cups port (it builds, but nothing locally runs) or stop
> recommending it.
> Or, does anyone else have it working on FreeBSD?  Sure would like to
> hear about it, but I've been trying for a long time now, with no
> success.
FWIW I had cups working (2 USB and 1 parellel)  forever on three
separate FreeBSD systems until last fall sometime. It had stopped
working on each of them after an upgrade that I have long since forgot.
After going through all of the removals and reinstalls, I compared what
was installed on these systems with a Linux box that cups worked on.

I found that I needed the /print/foomatic-db
and  /print/foomatic-de-engine ports. After I installed these two ports
cups is working fine on my FreeBSD systems. 


More information about the freebsd-questions mailing list