selected port (devel/root) is marked as broken

Mel fbsd.questions at
Wed Mar 12 18:16:50 UTC 2008

On Wednesday 12 March 2008 16:59:48 Luca Presotto wrote:
> Hi,
> 	I often use have to use root a program that has been ported to
> freebsd.
> If I try portinstall or I go into the directory and do make /make
> install I get "selected port is marked as broken: Does not compile"
> Or maybe a slightly different error with the same meaning.(I'm not on
> that machine now so I cannot cut and paste)
> That's ok, but I want to have root on freebsd to be able to use that
> machine more often.
> I downloaded the sources from then I tried to compile them.
> The suggested way is to use a provided script where you type the OS and
> the arch of your machine and it sets up everything for you.
> But this script supports only freebsd4/5/6, not 7.0 which I'm currently
> using.
> I tried telling him "it's 6" but then when compiling I get some errors,
> as announced by the previous messages!
> What can I try to be able to compile it?
> Will that be hard to do?

It fails on gcc3 specific classes. FreeBSD 7 uses gcc 4.x, so the problem lies 
with root developers. could install lang/gcc34, then:
make -DTRYBROKEN CC=gcc34 CXX=g++34

I'm not sure it'll work though.

Problem with today's modular software: they start with the modules
    and never get to the software part.

More information about the freebsd-questions mailing list